Where is the admin page

Over on the emonSD next steps thread, I foolishly started a sub-discussion. It got to a point where pb66 asked me some questions and stated some things and my response didn’t get an answer that was useful to me. So I’m reposting my last message as a new topic to see if I can move forward:

Do you have the setting I pointed too in settings.php?

$allow_emonpi_admin = true;

Can you post the server info from the button on the admin page?

Sorry, this will seem very dumb but what is ‘the admin page’ and how do I get to it?

you may need to stash your flot changes to do so, check the update log to see if it was successful

Sorry again, but how do I do that?

Sorry Dave I thought your questions had been answered, but I just took a look and you’re right, they didn’t get a proper answer, so here goes . . .

The admin page is only accesible when an “admin” level user is logged in AND the logged in session is still at admin level. Sorry that last bit maybe confusing, but that’s how it is.

When you register your first user, they are “the admin” and userid 1. That first user has the ability to set other users as admins, but for the moment I will assume you have only got one user and that user is an admin.

When that user logs in the session is an “admin level” session and if you check the menus at the top right there will be an “admin” entry below your “account” entry under “setup”. Clicjk “admin” to get the admin page.

However, the “rememberme” feature of emoncms, used to extend the timeout of a logged in session, doesn’t extend the admin level session. So after a while your admin level session will become just a user level session and the admin option in the menu will disappear.

You need to log out and back in again to get it back. Try logging out and back in to see if you gain the menu option. If not then there maybe an issue we need to look into.

Most of the Admin page is self explanatory, so rather than describing all that you are missing, I’ll wait till you get in and you can ask about anything that isn’t so obvious.

That was my bad, I had assumed you to be fluent in the black arts of Git since you were on a unusual branch, one that you must of switched to yourself as it isn’t automated.

If I were you, I would make a copy of your changes by using cp to make duplicate files or if they are all in one folder/file duplicate that, eg cp the flot folder to “/home/pi/myflot” for example, I don’t know the extent of your changes so cannot be more specific offhand.

Copying within the emoncms directories or using stash may not work because you also need to change branches as the branch you are currently on no longer exists since it was merged into the stable branch.

Once you have a safe copy of your changes, try

cd /var/www/html/emoncms
git checkout -f stable
git pull

the last line above might not be needed if you have managed to find the admin page, at which point you could use one of the update buttons to fully update the image including emoncms.


Oh! and

That’s good, I only asked if that setting was correct as I thought you were saying there was no update button on the admin page, we now know you hadn’t accessed the admin page.

Admin == Administration


Thanks, Paul. This was the magic information that I didn’t have and was unable to find by searching. It really should be documented somewhere and maybe a greyed-out entry in the menu when it’s not available would help? Especially with a tooltip explaining how to un-grey it? :grin:

I did it myself, yes, by following instructions @TrystanLea gave me. I realize I need to learn more about git, but I’d rather not conduct my learning experiments on my production emon system, so thanks for the steps to change back to the stable branch.

you have to logout / login again to see the admin page