Community
OpenEnergyMonitor

OpenEnergyMonitor Community

V440 Voltage errors - Sample Averaging?

Hi, Using a bench power supply, I calibrated16 x v440 modules at 3.6v (so all were within 3-5mv of one and other) ( Module version 440 / [ae014f40] @ 9K6 baud), I then checked them at 2.5v and was surprised/disappointed to see that they were all reading about 2.551V. This was a larger error than I had been expecting, but probably not too much of a concern for my application. I decided to check a range of Voltages in 0.01v steps, which produced the resulting graph - between 2.4 and 2.5v I suspect it may be a software issue as it is entirely reproducible, but so far have been unable to figure out what’s going on… Does anybody have any ideas or suggestions? Thanks Ken

Hmm… Maybe the MCU’s ADC has some weird behavior in that region. I believe the default now is to take the average of 5 samples. I can’t remember wat the step size is, but it is only like 3mv or something per step.

@Ken_Downie far from scientific, but I tried to repeat the experiment today, using bench power supply (Riden RD6006).

Going up in steps of 0.1V and down in 0.05V.

I didn’t see anything obviously wrong, there was definitely a step around 2.5V where the diybms read 2.55V for 2.50V input, but everything else appeared to be as expected and the two modules I was using were in lock step with each other.

Hi Stuart, looks like something’s just a bit weird with my setup. Thanks for looking into it for me. I’ll let you know when I’ve worked out what was going on.