Upgrade to new Emonsd from old software version

I have an old system consisting of RPiv1. 2 x emontx3 running on 868 freq which I know is discontinued. Running fine.
I purchased a new preloaded Emonsd card from the shop as I want to log locally rather than have to pay to store data which I am doing atm. I inserted the new bigger card and edited the emonhub config for baud rate, freq and API key to see if it would work with data export as I have now before changing to local logging.
It did not work! the log file just repeated 'RX data length 24 is not valid for data codes h,h,h,h,h,h,h,h,h,h,h,L
Have I missed something in the config? Please help sorry not at all skilled at this!

You could try and import your exisiting setup and data Import / Backup - Guide | OpenEnergyMonitor

I have the same config file as the old one but it doesn’t work. something to do with the data codes according to the log. Data codes are the same in each config.

OK I have it now from Glyn. It won’t work with an 868 system

Really? I have (almost) the latest running at 868 MHz.

Are you sure? If you have exactly the old config file, it should recognise the old data format from your emonTx3. But if you’ve got the data format for the latest emonTx software in the config file, that’s when you get the error

It looks as if there’s one ‘h’ too many – h = 2 bytes, ‘L’= 4. Adding them up, I make it 26 (which is what the latest emonTx sends), not 24 which is what your emonTx is sending.

In your config file, you need to change that twice (each emonTx) and you need to set the R.F. frequency:

[interfacers]
### This interfacer manages the RFM12Pi/RFM69Pi/emonPi module
[[RFM2Pi]]
    Type = EmonHubJeeInterfacer
    [[[init_settings]]]
        com_port = /dev/ttyAMA0
        com_baud = 38400                        # 9600 for old RFM12Pi
    [[[runtimesettings]]]
        pubchannels = ToEmonCMS,
        subchannels = ToRFM12,

        group = 210
        frequency = 868
        baseid = 5                              # emonPi / emonBase nodeID
        calibration = 230V                      # (UK/EU: 230V, US: 110V)
        quiet = true                            # Disable quite mode (default enabled) to enable RF packet debugging, show packets which fail crc
        # interval =  300                         # Interval to transmit time to emonGLCD (seconds)
1 Like

Thanks Robert. I did count the bits but was not confident as I am not good at this stuff! And, the old config file (years old) shows emon tx3&4 with 11h’s and L and emon tx1&2 with just an h. I believe I am using 1&2. I have other questions which I would like to direct to you about emontxwifi transmitting to raspberry Pi on same LAN that I am also struggling with. Emontx has latest firmware. Wifi is connected to LAN. its just the data flow that I cannot sort. Then I have to send data from 1 Pi to another over the LAN which I can’t do either! I need idiots guide I am afraid!

OK I have the new Emonsd and software working with my 868 system now. My other questions above still apply though.

The emonHub log tells you which nodes it is receiving from.
RFM2Pi 423115 NEW FRAME : OK 5 148 0 161 0 ...
the ‘5’ immediately after OK is the NodeID.

OK, first the emonTx. I take it you mean with the ESP8266 module?
You enter in there the Pi’s IP address, and the data goes straight into emonCMS, NOT via emonHub. So there’s nothing to do in emonHub, and it won’t show up in the emonHub log. The first place you’ll see it is on the Inputs page of emonCMS.

Data from one Pi to another.
One is the emonPi/emonBase of course, what about the other? Why, and where is the data going? There are too many variables without knowing that.

If you haven’t already done so, you really need to tell your router to use a fixed IP address for each of these things, otherwise if it decides to give some of them different addresses, it all falls apart.

Thanks again Robert. The software is running fine now and I am processing locally which is what I wanted.
ESP8266. so I enter the IP address into the emoncms section of the ESP8266 software? Are any other entries required?
2 emonbases: My 1st system ran on 868. I came to expand it and found 868 no longer available. So I purchased a 433 emontx and emonbase. I used them both to send data to the same API key at emoncms.org. Now I wish to use one emonbase to process locally so I need to get the data from the other one to process locally.

I’m fairly certain that (plus your WiFi password) is all that is required. See Using the emonTx v3 with the ESP8266 Huzzah WIFI module - Guide | OpenEnergyMonitor
You might want to give it a node name.

I see. In that case, you do exactly as you did for emoncms.org, using the (hopefully fixed) IP address of the other emonBase.