Community
OpenEnergyMonitor

Community

Updated OS on emonPi and now nothing

Hi,

Performed a OS system upgrade this evening, and now all I get on the display is the top line full top to bottom with dots any ideas?

Can you post a screenshot please.

Upgrade from what version?

What hardware is EmonCMS running on?

Hardware is from about 12-18months ago, bought from the shop.

Last update was done in October which went through fine.

Andy,

Did you do the update manually (sudo apt-get update/upgrade) or via the GUI?

Manually.

Should it only be done through the GUI?

I think that’s correct. I can’t remember all of the details, as it’s been some time ago,
(and IIRC, @borpin mentioned that a manual upgrade should no longer be an issue)
but I can remember a thread on the forum that talked about a manual upgrade breaking things.

OK. Thanks

Can’t even getting anything out of it from the HDMI.
I guess I’ll have to flash the sdcard and see if it will boot then. If it doesn’t I’ll have to assume it’s a hardware issue.

On further investigation, the pi on its own won’t boot. The power light remains on, no other lights, no networking lights. And has a fair burnijg smell from behind the HDMI port. So I’ve ordered another one.

Bummer that it went south on you. But at least you did find out what the problem was.

1 Like

Sorry to hear that @deano! that doesn’t sounds too good! Strange that it should start happening on OS upgrade? was it giving trouble beforehand? anything that might have indicated that there was a problem?
@glyn.hudson any ideas on this?

When you build the system up again take a look at this guide here on upgrading and importing from an old SD card it may provide a way to recover without loosing historic data - if you were recording data locally? https://guide.openenergymonitor.org/setup/update#upgrading-to-a-new-emonSD-image

1 Like

Hi,

Just as way of an update.

The graphing had stopped woring randomly for the amount of electic I was using in all dashboards that I had configured, hence the reason I thought I’d update it. Then on reboot got the errors and issues as per my OP.

New pi board fitted, booted but with kernal panic, reflashed SD card, booted, did a manual upgrade, rebooted all fine. Created an account, restore my last backup and loggd out and back in again. All working.

Just need to configure my Octopus Agile dashboard as it doesn’t have appeared to have saved this, which is a bit unfornite as it takes me a while to get the inputs right.

1 Like

There is a strong suspicion that the issue was not with the hardware but the SD Card. Always the first things to go.

After the SD Card had been reflashed, I checked it booted on the new board, put it back in the old board and got exactly the same issue as described in the OP. SD Card back in new board and booted. So I highly doubt on this occasion it was the SD Card.

Just out of interest, have you tried a new card in the old Pi? Did you change anything else like power supply?

Worth knowing for future reference. The problems you saw are usually solved by a new card and not a new Pi. The RPis are very robust.

Actually the opposite, @Bill.Thomson, whenever possible do updates from the GUI as the update script does more than just upgrade the repositories (depending on age of system and current version).

That’s indeed usually the case. Except in this instance, he mentioned a burnt component odor.

In 45+ years of Electronics “Teching” it’s been my experience that any time you see smoke
or smell burnt component odor, some kind of hardware failure has occurred. When things go
south in that fashion, it’s not unusual for other parts in the “system” to get taken out as well.
i.e. that’s likely the root cause of the SD card corruption.

Looks like I didn’t recall correctly. :wink: :grin:

Oh I missed that :man_facepalming:

To confirm new SD Card in old pi made no differnace.

1 Like

Yes, I’d missed the info re burning smell :man_facepalming: