Unable to order assembled controller at JLCPCB; "Min. PCB dimension for SMT Assembly is 10x10mm"

hope somebody can help me.
I am stuck with an order for the V4.40 controller of diyBMS.
I can upload the gerbers file ( diyBMSv4/controllercircuit_esp32_gerbers.zip at master · stuartpittaway/diyBMSv4 · GitHub ) but i can not proceed with the SMT Assembly. The web form at JLCPCB will complain about the PCB dimension.
I also tried another gerber.zip ( diyBMSv4/gerber.zip at master · stuartpittaway/diyBMSv4 · GitHub ) but the problem is the same.
The software at the JLCBCP website seems to expect the “dimension” of the board somewhere in the gerbers file.
Did you all create your own gerbers when ordering from thsi site?
Or am i doing something wrong here?
Thanks for your help,

best regards


Most likely this is an error when entering the gerber or assembly request on the web form. I’ve always used the gerber zip as delivered by @stuart for ordering controllers and modules, including assembly of parts that they have in stock.

Can you share a screen shot of the order page showing the failure?

Thanky you for trying to help Mike.
I solved it already.
it was a problem with the gerber zip file that i “downloaded”.

When i click on this one

[DIYBMS for Lithium Iron Phosphate battery cells (LiFePo4) 280aH - #184 by vas]
(DIYBMS for Lithium Iron Phosphate battery cells (LiFePo4) 280aH - #184 by vas)

then i am able to use it for the jlcpcb form. It will show an image of the front and the back of the board and i can do everything just fine, including SMT assembly ordering.

With the downloaded file from stuarts github that was not possible.
It did not show any image and the “dimensions fields” of the web form were empty.
No SMT asembly ordering possible.

I am on macos and using firefox mostly.
When i clicked on the file in my file browser ( after the download ) the file turned into “gerbers.zip.cpgz”. After clicking on that file the file turns into “gerbers.zip” again.
That seems to be a common problem on macos with some downloads on some browsers, according to my research.


Now i tried to download the file with apples safari browser and it just saved the html-link.
So what was necessary, and worked with both browsers, is to click on the file on github and then you will see a page with a description of the file and two options.
See “raw” and “download” !!!

Long story short :wink:
I am able to order now…



Great! It seems that MacOS is converting the file to a different format for unknown reasons, much like some newer versions of Chrome insisting on converting jpg files to webp files when saving.