Unable to connect the OpenEVSE to wifi anymore

All of a sudden my OpenEVSE has lost the connection to my router and I cannot get it back for the life of me.
Nothing has changed, no router settings, nothing was moved, all other wifi devices are connecting without problems.

  • I have tried power cycling it from the breaker in the house, nothing
  • I have tried restarting my router/changing 2.4g bands, nothing
  • I have tried holding down the side button for 10s and it gives me the option to connect to it directly but when I check the wifi list my router appears/disappears and the wifi icon is greyed out.
  • Also it looks like holding for 10s doesn’t do a full reset as I can still see my original options there.
    Any ideas?


only idea I can think of is that someone has another device using the same channel that your router is on and it is nearer to the EVSE that yours. You could check if another device can see your router when you try it close to the EVSE (just make sure it is on 2.4 and not 5)


Tried changing channels on the router too, no joy.
The bandwidth was set to 20/40 mhz on the router and I tried 20 only, also no luck.
I’ll try connect it to a wifi hotspot on my phone, see if it connects at least.

Does the LCD display “OpenEVSE WiFi” a few seconds after being power cycled? Does it display an IP address a few seconds later?

Is the unit boardcasting a WiFi AP called “openevse-xxxx”?

Yes it is broadcasting the Openevse wifi and I can connect to it directly but don’t see the IP

When you connect to the access point can you see your home WiFi network listed? If so, how many bars of signal does it show? It sounds like the OpenEVSE could be struggling to maintain a connection due to weak WiFi signal.