Thresholds widget fails with 9.5.5

Trying to add this widget causes and un-exitable loop with the following error:

image

Hello @simmonslr, I think the error was caused by the widget not being able to find the feed that it was configured to use. Perhaps the feed was deleted at some point after creation of the dashboard?

I’ve fixed the check for this error in the dashboard module, now available in the latest master branch: fix thresholds widget, check for undefined feed · emoncms/[email protected] · GitHub

Are you running emoncms on a custom install or emonpi/emonSD image?

I am using a custom install running on Ubuntu.

Sorry if I’m asking a dumb question, but not sure how to access the latest master branch. Ran the following from the installation instructions, but it’s not get the latest branch:

# other notes -- optional steps for using unstable version
cd /var/www/html/emoncms
git pull
#then to switch branch to master;
git checkout master

Edit - formatted text for readability. BT - Moderator

great, the procedure is:

cd /var/www/html/emoncms/Modules/dashboard
git checkout master
git pull

I appreciate your help. I am still getting the error.

I ran the instructions you suggested, and the ‘git pull’ gave me a rather colorful screen with a lot of plus signs, etc., which I assume means it downloaded the latest changes.

When I brought up the dashboard, it showed version 9.9.5 again so I ran ‘git checkout master’ one more time. The version now says 9.9.6-beta, but as I mentioned, I still have the issue. Is there a way to tell if what I have includes your latest code changes?

Looks like I may have a caching problem. It works in a different browser. I will dig further. Thanks again.