# Symlinking services in Jessie doesn't work

**URL:** <https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220>\
**Category:** Emoncms\
**Created:** [24 February 2019 11:51 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220 "2019-02-24T11:51:03Z")\
**Posts on this page:** 13\
**Page:** 2

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 22:11 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/21 "2019-02-24T22:11:55Z")

</div>

> [@Greebo](#):
>
> If you ditch that line, or change it to `Type=exec` does the error about the `lvalue` go away?

No, it gives me the error either way, i.e. whether the line is there or not.

> [@borpin](#):
>
> Odd, cannot see why it should complain unless there is the same unit in the search path somewhere perhaps?

Made sure that didn’t happen.

---

<div class="post-metadata">

**Author:** ![Greebo](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/greebo/32/4556_2.png) [@Greebo](https://community.openenergymonitor.org/u/Greebo)\
**Post date:** [24 February 2019 22:24 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/22 "2019-02-24T22:24:42Z")

</div>

> [@Bill.Thomson](#):
>
> No, it gives me the error either way, i.e. whether the line is there or not.

> [@Bill.Thomson](#):
>
> The error message it gave me was:  
> `[/lib/systemd/system/hplt-pwr.service:6] Unknown lvalue 'type' in section 'Service'`

That exact same error, or a different `lvalue` error? If you’re getting that error without the `Type=` line, something else is definitely going on!

---

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 22:33 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/23 "2019-02-24T22:33:01Z")

</div>

Same error.  
The weird part is when I move the file to the /etc/systemd/system directory the error goes away.

---

<div class="post-metadata">

**Author:** ![Greebo](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/greebo/32/4556_2.png) [@Greebo](https://community.openenergymonitor.org/u/Greebo)\
**Post date:** [24 February 2019 22:38 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/24 "2019-02-24T22:38:55Z")

</div>

Ok, can you clarify exactly what you’ve done after you put the file in `/lib/systemd/system`?

---

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 22:40 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/25 "2019-02-24T22:40:08Z")

</div>

In /lib… or /etc… ?

---

<div class="post-metadata">

**Author:** ![Greebo](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/greebo/32/4556_2.png) [@Greebo](https://community.openenergymonitor.org/u/Greebo)\
**Post date:** [24 February 2019 22:41 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/26 "2019-02-24T22:41:11Z")

</div>

The issue of the `lvalue` error occurs when you put the service unit into /lib right? If so, then what did you do after you put the file in there?

---

<div class="post-metadata">

**Author:** ![andy\_l](https://community.openenergymonitor.org/letter_avatar_proxy/v4/letter/a/c67d28/32.png) [@andy\_l](https://community.openenergymonitor.org/u/andy_l)\
**Post date:** [24 February 2019 22:44 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/27 "2019-02-24T22:44:02Z")

</div>

> [@borpin](#):
>
> Do you use the RFM ‘emonBase’ on the Pi? In which case take care with the EmonSD as it assumes you have one of the newer RFM modules and does an update on that basis (unless you tell it not to).

I do use emonBase, but funnily enough I upgraded to the RFM69 receiver board because I wanted RSSI values. Good to know about the emonSD behaviour though.

> [@borpin](#):
>
> I was in a not too dissimilar position. A couple of years ago I bit the bullet and moved to a newer base. It was a pain but worth it in the end.

It’s not just about the base. For instance, the emonHub node decoder assumes your nodes conform to a particular ID range set by DIP switches, whereas mine do not. Other things like firmware have been forgotten about; for example the only emonTH 1.x firmware in Git is for 1.5 boards, as it includes JeeLib and all of the DIP switch logic. As this last version of firmware was the most optimised, I have ‘ported’ it back to my 1.4 boards by reverting to RFu\_JeeLib and pulling out the DIP switch logic, but it’s yet another ‘non-standard’ part.

So really it’s about the system as a whole and the amount of tweaks that become necessary during major emoncms releases.

Anyways, appreciate your advice - thanks.

---

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 22:44 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/28 "2019-02-24T22:44:13Z")

</div>

Enabled it, then checked the status to see if it was running.  
It _was_ running, but that’s when I noticed the error. Didn’t do anything else.

---

<div class="post-metadata">

**Author:** ![andy\_l](https://community.openenergymonitor.org/letter_avatar_proxy/v4/letter/a/c67d28/32.png) [@andy\_l](https://community.openenergymonitor.org/u/andy_l)\
**Post date:** [24 February 2019 22:49 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/29 "2019-02-24T22:49:06Z")

</div>

> [@Greebo](#):
>
> Much of the discussion happened in github and for various reasons there were numerous PR’s that ended up being submitted and the discussion spread over them. With that said, [this one](https://github.com/emoncms/emoncms/pull/1025) has the meat of it…

Aha! Thanks Greebo. Reading through that PR fills in all the gaps and confirms the behaviour I’ve been seeing.

Slightly frustrating though, because the Pull Request recommendation to have ‘special instructions’ for Jessie users never actually made it to the service install notes - if they had, we wouldn’t have this thread 😉

Thanks again,

Andy

---

<div class="post-metadata">

**Author:** ![Greebo](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/greebo/32/4556_2.png) [@Greebo](https://community.openenergymonitor.org/u/Greebo)\
**Post date:** [24 February 2019 22:53 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/30 "2019-02-24T22:53:13Z")

</div>

> [@Bill.Thomson](#):
>
> Enabled it, then checked the status to see if it was running.

Do you mean you ran the following?

```plaintext
sudo systemctl enable hplt-pwr
systemctl status hplt-pwr

```

If so, after doing that is there a symlink in `/etc/systemd/system` pointing to the file in `/lib/systemd/system`?

---

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 22:55 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/31 "2019-02-24T22:55:56Z")

</div>

Yes, those are the commands I ran. (with sudo prefixed to the status command as well)  
It put the symlink in /etc/systemd/system/multi-user.target.wants/

---

<div class="post-metadata">

**Author:** ![Greebo](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/greebo/32/4556_2.png) [@Greebo](https://community.openenergymonitor.org/u/Greebo)\
**Post date:** [24 February 2019 23:01 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/32 "2019-02-24T23:01:25Z")

</div>

Can you post the full output of the `status` command when the file is in `/lib/systemd/system`?

---

<div class="post-metadata">

**Author:** ![Bill.Thomson](https://community.openenergymonitor.org/user_avatar/community.openenergymonitor.org/bill.thomson/32/1834_2.png) [@Bill.Thomson](https://community.openenergymonitor.org/u/Bill.Thomson)\
**Post date:** [24 February 2019 23:24 UTC](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220/33 "2019-02-24T23:24:46Z")

</div>

Since it’s working, I’m thinking it’s best not to mess with it.  
I sure as heck didn’t mean to hijack the thread. _That_ wasn’t intended.  
I’m going to let it ride as is.

Thanks for taking time to troubleshoot it. ![thumbsup](https://community.openenergymonitor.org/uploads/default/original/2X/3/3c587556c0cc11389317c03a60788d77ceebd307.gif)

[Previous page](https://community.openenergymonitor.org/t/symlinking-services-in-jessie-doesnt-work/10220.md?page=1)
