Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Shutdown not possible - Stuck to booting

Tags: #<Tag:0x00007fe79f1586a8>

Hi all!

The emonpi was working properly yesterday and did an update. After that data were logged properly. But now the screen is stuck to “Bootting… Please wait” and cannot even shut it down from the reset button on the side.

Earlier, it was stuck to update mode for almost 6 hours (already updated yesterday). So I just unplugged it quicky and plugged again. After that is stuck to Booting.
I cannot even acess the emopi.local. What actions should I follow?

Thanks for your time.

Just because the LCD says booting does not mean it isn’t accessible. Have you tried the webpage or SSH?

Yes, I have tried to load the webpage but is not accessible.

Hello @Ioanna do you know how old this emonpi is and when you last updated before your most recent update?

Hi! So the device was firstly installed in December 2019 and the last update was in August 2020. After that it was yesterday that I re-used it and it worked properly for 1 day

Ok, doesnt sound too old, I cant think of a reason the update would have failed if the August one was fine. Your best bet is probably to update using https://guide.openenergymonitor.org/setup/update/#upgrading-to-a-new-emonsd-image

Thank you all for your answers. It seems that for some reasons the last twi days it just gets stuck at some point and have to unplug it and plug again.

In this case it seems that the past data are not presented in the emonpi.local page, so I was thinking that I should send them to Emoncms.org, right? And there I can access the past values.

However, I followed the step of copying the write API key to emonhub of the local page, saved it and nothing happened. Feeds and inputs are not presented to emoncms.org.
I have checked the log file and it seems like puplishing the data (screenshot attached). Do you have any idea of what is the reason ?