Safari issue with Emoncms 10.2.7

I am trying to use an iPad as a display monitor for both Apps and Dashboard; this was successful until I updated to the current version, 10.2.7. I have no problem accessing these using later Apple Mac models (Mac Pro and Air, and a 5 year old iPad Air). However my older iPad only gets as far as the log in screen, and the Safari debug console gives the following 2 errors resulting from /Lib/emoncms.js?v=10:
JavaScript: Error on Line 34 - SyntaxError: Parse error, and the same on Line 45.
If I try to log in, it adds 2 additional errors: undefined. ReferenceError: Can’t find variable: path.
Does anyone know if this is fixable? Screenshot of debug screen attached

I have now rebuilt the iPad (again) back to original and still cannot access emoncms, but at least Safari debug now only gives a single error. “Can’t find variable: path”, screenshot below.

Then, when retrying a second or more times, the full 4 javascript errors are shown in the Safari debug console as above. Any help will be very welcome.


Can you try a different browser?

Good suggestion, thank you. Unfortunately I tried this but my early iPad is no longer supported through the current Apple Mac store, and the legacy apps that are available do not include any browser alternatives. When it was fully supported I was using Emonpi 26 Oct 17 image which worked perfectly with Safari 5.1.1 which is the most up to date version I can use.
Other browsers which were available (Opera, Firefox) have not been kept as legacy versions.
I inadvertently updated Emonpi when I took delivery of a solar battery and needed to change my NodeRed EV charging program; I cannot regress to the 26 Oct 17 image but have tried very many times. The Emonpi support team cannot help me as they are unable to deal with legacy issues, and advised I use their latest software.
I have now rewritten my NodeRed programme on this latest version to successfully manage the conflict between the solar battery and EV charging, but cannot use my wall mounted display (the old iPad) even though it is still able to connect and properly display other commercial websites. This indicated to me that the issue is within Emonpi so I was hoping someone would be able to assist with the Javascript problem identified by Safari. I would have a go but I do not know how to access this code. I have tried to navigate to the directories indicated by the above Safari console but /Lib/misc. and /Lib/emoncms do not seem to be available.
I have also considered jail breaking the iPad but I am unaware of an alternative browser that would be able to be used.
I thought this was a great use for an old iPad – a permanent energy display, been great for the last 5 years. What do others use for this purpose? A new iPad is a bit pricey.

I had this too on my ipad 1. It has to do with the version of javascript.
Another browser won’t help because they all use the same web-kernel as safari.

A second hand ipad that will work with the current javascript won’t be that costly, but it will probably stop to work on another issue in say 3, 4 years…

That is really good information. Because the old iPad still works with commercial websites, and worked with the emonpi 16 Oct 17 image, but not with emonpi latest, I assumed it was a recent emonpi issue. Looks like I cannot keep the iPad for this purpose - bit of a shame really, as other than this javascript mismatch it is an excellent screen. Second hand older iPads are nearly half price, and as you say they will likely become obsolete in a few years. I find a wall mounted display for the emonpi apps and dashboards are really excellent for real time monitoring, especially when keeping an eye on EV charging at 11kW, or from solar energy only. Decisions now need to be made… Many thanks.

I will try to get this fixed, can you see any line numbers or any further information on the path error specifically?

Hi Trystan; Since the information from Thelmike I have been researching the iPad1 to confirm that the version of javascript cannot be improved, so I am resigned to purchase a replacement. If you can resolve the issue - fantastic, it will provide all Emonpi owners with a very cheap wall display as iPad1’s are not otherwise very useful other than browsing. I attach the following for your perusal:
2 screenshots of other websites (news site and TMC) to establish a baseline that the iPad will connect;
2 screenshots showing the Emoncms log in screen with the 2 errors from the debug screen and
2 screenshots showing the log in screen filled in and the additional error. Further attempts to log in adds a repeat of this error in the debug screen. Best of luck and thanks for your efforts.

Hi Trystan, did a solution ever arrive for this?

I’ve just set up my Iotawatt as a source into emoncms and thought my old, unused, iPad 1 would be perfect to have as a display but, like Keith, I can’t get past the log in screen, I tap on Login and nothing happens. The iPad is as up to date as I can make it running iOS 5.1.1 I know it’s a long shot but the browser is about the only thing an original iPad is good for and this would be a perfect use for it, if it’s at all possible.

What are you trying to display?

If just graphs or dashboard, make it public and see if that works on it’s own.

Old browsers are not supported, unfortunately.

I was trying to log in and view the my solar app. I don’t think that’s available publicly so I guess I’d have to create a dashboard and make that public. Thanks for the suggestion, I’ll figure out how to build a dashboard next and try that.

Hi all - I developed my own dashboard and made it public to avoid the log in issue on my iPad 1. It managed to connect to the dashboard and show the outlines and some titles of my required graphs, but failed to show any data or graph and complained about 14 javascript errors. If interested I could repeat the log in and post these errors. I eventually gave up and bought another iPad which has become my display.

Yes my suspicion is that the Browser is simply too old.

Agreed, which is why I bought a new iPad. However what I do not understand is why I can successfully browse any number of internet sites. The only explanation I can figure is that emonpi uses a lot of more up to date javascript commands than some internet sites - the attached screenshot from my iPad 1 is from The Age online newspaper this morning.

I have the display running on an iPad 4 in the kitchen which does the job, I just thought I’d put one in the hallway as I had the old iPad 1 spare. Looks like I’ll be keeping an eye out for an old iPad or use my current 5 year old iPhone when I upgrade that in a year or two.