Community
OpenEnergyMonitor

Community

Rpi-rw is not recognized by the software

Tags: #<Tag:0x00007f6e0fbc7aa8>

When I ssh into my rPi (emonbase), it doesn’t recognize the rpi-rw or rpi-ro commands, even with sudo. I just updated also. What have I missed?

I think you’ve missed that they are no longer needed, following the re-organisation of the software.

Ah. Thanks. Yes, I was unaware of that.
Hoever, I still have problems applying the script to program the RFM69 assembly.

Reef

I’m not an emonCMS expert, are you running emonCMS? If you are, and it’s the latest version, then on the Admin page there’s an Updates button with a drop-down. In the drop-down there’s an option “UPDATE FIRMWARE ONLY” and a further selection for emonPi, RFM69Pi, RFM12Pi or custom.

If you’re not running emonCMS, then my notes say these are the instructions:
https://wiki.openenergymonitor.org/index.php/RFM69Pi_V3#Upgrading_RFM69Pi_Firmware_Direct_from_the_Pi

You’ll need to find the correct source file - I know things have been moved around since that was written, I don’t know where it might be now; and you also need to know that over time, the baud rate has changed too - my notes say it can be 9600 or 57600.

If none of that makes sense or doesn’t work, I’ll call in someone else. And then get those instructions updated.

I’m going to lock this thread as you’ve asked the question again: Emonbase no longer communicates with peripherals after update