RFM2PI Not Broadcasting Time"

Hi all,
Local install of Emoncms Low Write 9.8.4: 2017.05.01
Release emonSD-07Nov16.
Running on RPi2 with RFM69Pi module (EmonBase installation)

My EmonGLCD is showing the wrong time as the Emonbase Node ID15 is not transmitting any time.
The Emonhub.log file has no entry re the RFM2PI Broadcasting time…?
I have set the Time “interval” to 180sec and changed the BaseID to 15 as I am using a emonbase installation, but still no entry in the Log. Any suggestions to what could be wrong is greatly appreciated.

In theory what you have done should work.

Your [[RFM2Pi]] [[[runtimesettings]]] section of emonhub.conf should contain this one line

            interval = 180

although 180 is possibly far faster than required, it’s usually set to 300 which even that is maybe overkill. However whilst trying to get up and running try setting it to 10 as it is very easy to lose the log entry when searching the logfile when it only happens once every 3 (or 5) mins.

After setting the interval to 10 can you please post 30sec or more of emonhub.log including the period from when you changed the setting so that we can see if the setting is accepted correctly and then 1 or 2 send intervals so we can see if there is any attempt to send and if so what the results is.

Hi Paul
I have checked the emonhub.conf and it does contain the line interval=180.
I have now changed it to interval=300, which is correctly shown in the emonhub.conf, but still no log entry in the emonhub.log re “broadcasting time”
Will post details tomorrow.

What a difference a day makes. Got ready to post the details and decided to have a good look at the Emonhub.conf file again. Bingo, I did not remove the “#” before the interval=180 statement, when removed it all works perfect and the EmonGLCD is happy showing the correct local time.
Many thanks Paul for getting me to focus more.