OpenEVSE PV Divert Fluctuates Above and Below Net Grid Power

I got my OpenEVSE subscribed to the grid net power topic on my energy monitor. Turned on Eco (PV divert) for the first time and what I’m seeing is that it oscillates between drawing too much and too little power. It will charge at 29A for a while and will display “-2790W - 10s | Charge rate: 29A”, then after about 10 seconds it will switch and display “2894W - 3s | Charge rate: 6A”.

My MQTT topic is published every 10 seconds, which doesn’t seem like a coincidence. What am I not seeing?



When the car is not charging and your PV is generating more than your house is consuming does you gird feed go negative? The OpenEVSE should show this negative number next to the Eco switch on the OpenEVSE web interface.

The power drawn by the OpenEVSE should be included in the grid feed.

The correct charging rate should be around 16A if your PV is generating 4.9kW and your house is using 1kW (4900kW - 1000kW / 240V = 16.25A)

Could you share some screenshots of your OpenEVSE setup and your Emoncms Inputs and feeds page?

I tried again later that day when I needed a charge again and it worked. In the image you can see it behaving as expected. So I don’t think it was a problem with the setup.

As to why it didn’t work the first time, it seemed like it was stuck in a bad loop, where it would react to the available power by turning up the charge too much, then react to the resulting lack of surplus power by turning down the charge too much, oscillating between these states every 10 seconds. I can’t prove that is what it was doing or explain why, though. I’m moving on and will keep an eye to see if it happens again.

I do have a question. Is it important to pause charging before enabling eco charge? In particular will these sequences cause any issues?
Start normal charge > enable eco mode without pausing
Enable eco mode before plugging in vehicle > plug in vehicle to start charging

Great to hear it’s working correctly now. Let me know if you have further issues.

No it won’t make any difference. I often plug in (charging starts max rate) then enable Eco mode (charging reduces to PV surplus).

Pause/sleeping is only needed if you wish to plug the EV in the evening when the solar PV has stopped generating and have the EV automatically start charging when solar PV starts generating 1.4kW+ in the morning. To do this pause the charging then enable EcoMode (or the other way round, makes not differance). EV will then resume charging when solar PV starts generating in the morning.

There has been a report of Renualt Zoe’s failing to resume charging when paused since the Zoe seems to go to sleep after a while. A work around is to charge normally for a few seconds before pausing the charge, see: