Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Openevse - problem retaining the charge connector

Hi,

I have Openevse hooked up to Home assistant through MQTT and all worked well since installation a few months ago. In the last few days I noticed openevse seems to struggle turn on the charge and keep it on. Relay keeps clicking on and off within a few seconds interval… No recent upgrades, changes or anything it just stopped working reliably as it did for the last few months. I have captured what it does in the debug logs below:

{“state”:2,“vehicle”:1,“colour”:3,“manual_override”:0}
{“amp”:0,“voltage”:240,“pilot”:32,“wh”:2365734,“temp”:173,“temp1”:false,“temp2”:173,“temp3”:false,“temp4”:237.5,“state”:2,“vehicle”:1,“colour”:3,“manual_override”:0,“freeram”:213800,“divertmode”:1,“srssi”:-67}
{“state”:3,“vehicle”:1,“colour”:6,“manual_override”:0}
{“amp”:31240,“voltage”:240,“pilot”:32,“wh”:2365734,“temp”:173,“temp1”:false,“temp2”:173,“temp3”:false,“temp4”:237.5,“state”:3,“vehicle”:1,“colour”:6,“manual_override”:0,“freeram”:213752,“divertmode”:1,“srssi”:-64}
{“state”:2,“vehicle”:1,“colour”:3,“manual_override”:0}

As I understand state 2 is connected, state 3 is charging followed by amp message. But I cannot see anything above to suggest why it changes from state 3 to 2 again. there are no timestamps, but it stayed on state 3 for about 5 seconds before stopping charge and changing to state 2 again. I only pasted the output of one cycle, it keeps doing the above in a loop.
Before it started to behave like this full-time, it did eventually manage to keep the charge on after going through several cycles of on/off late last week. I just could not get it to work last night as my night tariff kicked in, ended up going to bed defeated on granny charger at 2am and short of miles in the morning as a result!

I first thought it was home assistant flows messing about, but having HA completely diconnected off the network I observe exactly the same behaviour when controlled EVSE manually from the web page. I only bought it a few months ago, looks like there is a fault with the variable relay potentially? Is there anything else I’m missing? Anyone seen similar behaviour?

The change between state 2 and 3 or visa-versa is determined by the car, from the EVSE POV we just tell the car it can charge, then the car chooses to charge or not. If this was something the EVSE was doing it would switch to state 254 (sleeping).

Is there any error showing in the car? What type of car is it?

MG ZS EV is the car. It’s been a bit of a nightmare with scheduled charges tbh, but eventually got it to work and it has worked stable since May when I had openevse installed. Started doing this latter part of last week. Just waiting on a mate to come over later to try on a Kia to verify whether it’s the car or EVSE. I have charged the car in numerous public chargers (of various sizes: 32Amp, 13amp and rapids) this weekend - it was absolutely fine. It also charges fine on 13 amp granny charger right at this moment.

Further update - I had two other cars come over and get plugged in - EVSE behaves the same. Stops and restarts the charge after having charged a bit (anywhere between 5 sec and 10 min - completely random it seems). The difference on the other cars is MG had later BMS installed, which ensured the car still charged albeit disrupted by EVSE, same for the other car - Kia Soul. There clearly seems to be a fault with the unit, firmware is the same etc as can;t be upgraded it seems, yet the behaviour has changed. Any experience how this can be rectified? Unit is only a few months old and obviously arrived “in pieces” rather than a whole unit, I would imagine only one part may be what’s causing these issues, not the whole lot, how do I identify what though?

@glyn.hudson any ideas? Maybe there is not a good connection on the pilot? Are you able to check the voltage?

Yeah I can. If you tell me when he connectors and what voltage I should be expecting

If you measure the AC voltage between the PP IEC and the CP Control Pilot connections you should see:

  • Connected, not charging, 10.5 V, (+9 - -12)/2
  • Connected, charging, 9 V, (+6 - -12)/2

For what it is worth on my test setup I get 9.955 V and 8.681 V, my theory would be that you will see something in the middle in both states

Ref: Basics of SAE J1772 : Support