OpenEnergyMonitor Community

OpenEVSE pause state - what does it really do?

The newer firmware has an option under advanced which states …

“Some vehicles will shutdown if left in sleep mode (pilot signal enable) and then can not be woken up by timers/PV divert. Changing the pause state to disable should resolve this issue, however this removes the ability for the charger to detect if a vehicle is connected when paused.”

My unit now has to charge two vehicles, an MG5 and a ZE50 Zoe. The Zoe does a 60 mile commute Mon-Fri so is plugged in the same evening and charges fine on a timed charge to match Octopus Go.

Now I have my MG5, that gets used a little during the week, gets plugged in on Sunday and charges on a timed charge fine.

Last week I used the MG5 quite a bit and did a longish journey on Saturday so down to about 27%. Plugged it in on Saturday evening and it charged for four hours overnight but wouldn’t have reached 100%. So I just left it plugged in but it didn’t charge over Sunday night and there’s my problem.

I think both the MG5 and MG ZS don’t implement the charging protocol correctly in that if it charges and then stops, it won’t start again if there’s more than 10 minutes worth of delay.

So my question is will the option to disable pause solve my problem (yes, I’ll try it the next time but …), and what are the side-effects i.e. will it have an impact on the Zoe, will it continue a trickle charge (which I know some other units do to get around this) etc.? Is the ability to detect a vehicle an issue or is it just transparent essentially?

I changed the pause state to disable and the Zoe still charged overnight which is good else I’d have had an earful this morning; TBH can’t see what has changed from the app values/display but now need to see if it resolves the problem I saw with the MG5.

I fully intend to have that car plugged in daytime once the weather gets better and I have some excess PV to divert; the current situation would seem to preclude that working.

If the vehicle has implemented J1772 protocol correctly just using normal ‘sleep’ state should be fine, the EV should wakeup and charge regardless of how long ago it was plugged in or how many times it’s charged before.

However, it sounds like you have experienced an issue when the vehicle does not follow the protocol. Using ‘disable’ mode to disable the pilot signal may help, this is a bit of an experiment, all bets are off since the vehicle is not behaving as it should do. However, using ‘disable’ to remove then restart the pilot signal entirely may wakeup the onboard charger and kickstart a charging session. You should not notice any detrimental effects using ‘disable’ instead of ‘pause’.

Let us know how you get on.

I believe MG has updated the firmware to fix this issue, as least on the MG ZS, I’m not sure about the MG5. Some early Zoes also had this issue, but again I think it’s been fixed.

The trickle charging trick that some EVSE’s have implemented is not a great solution since the slowest ‘trickle’ an EV will support is 6A / 1.4kW which is not really a trickle! Most users would not want the EV drawing 1.4kW continuously during peak electric tariff times. Also trickle charging is very inefficient, under 10A a Zoe is less than 50% efficient :grimacing:

1 Like

I normally just charge on timed. I suspect if I’d just opened and then locked the car, it would have charged OK the next night.

I’ll do a quick test today - charge for 15 mins, switch off for an hour or so and then try again i.e. something similar I guess to what the PV divert will do once the weather improves.

Well that seemed to work; charged for fifteen minutes, I stopped it for over an hour and it restarted OK.

I’ll retest with the sleep re-enabled and see what happens then - expecting the second charge not to proceed I guess.

Final update.

After the above I re-enabled sleep and started charging which went OK.

Stopped and left it for about 30 minutes and then tried to charge again - state went into ‘EV Connected’ but no charge. After 10 minutes of this, I paused the (non-)charge, disabled sleep, started charge, state went back into ‘EV Connected’ and then very soon afterwards ‘Charging’.

So it seems to solve the problem and haven’t noticed any new issues as a result of that setting.


Should have known better. After yesterday’s tests with my MG5, I left the unit with sleep disabled and unconnected/moved my car.

Wife got home from work, plugged in her Zoe as usual and told me the lights on the charge port weren’t the same and that the unit itself said ‘disabled’. Don’t worry was my response, it’s supposed to be like that now.

Of course, the timed charge overnight didn’t happen. She can get two commutes out of the Zoe (and could possibly squeeze in three) but I need to ensure it charges tonight so I’ve switched sleep mode back on, fingers crossed and I guess I’ll have to workaround the MG5 problem.

I was told today that “the MG software requires the CP line voltage to be dropped to 0 or -12v for more than 3s before it will wake the car up”.

I’m trying to fathom out the source code to see what the sleep disable does.

Is there a walk-through / code description available anywhere?

Disable sends RAPI command $FD to the openevse controller to stop a charge which disables the charge point (removes pilot), normally $FS RAPI command to pause the charge.

See OpenEVSE controller FW for how the pilot is handled: