Community
OpenEnergyMonitor

Community

OpenEVSE and MTU

Well, this might be a bit of a strange question, but has anyone been able to talk to openEVSE via a VPN or other connection with non-standard MTU?

When I connect back to my home network I can talk to my EmonPi but not to the OpenEVSE…

As an experiment I changed the MTU on the LAN interface of my laptop, which created the same issue, i.e. no access to the web interface, although ICMP pings still worked.

Has anyone else seen this? Is there a workaround? Or new code?00

This is a known issue for the ESP8266 WiFi gateway, see:

This issue has been fixed in the ESP32 version, this version will require a hardware upgrade (ESP32 Huzzah) and the FW is still in beta but has reached feature parity with the ESP8266 version:

aha - thanks Glyn!

I did look on GitGub but clearly missed this. do I read this right in that it will need new hardware? If so, how can I tell what I’ve already got? Still on a steepish learning curve with the whole openenergy ecosystem!
Cheers
Tim

Yes, this requires changing to ESP32

You will have an ESP8266. We have not started shipping ESP32 since the FW for this is still in beta. But is fully functional if you wanted to help test. It’s very close to being ready for release.

Bit concerned about the Wife Acceptance Factor :wink: She wants me to sort out the solonoid Menekes lead lock first. Even that breaks me into a cold sweat - as I’ll need to recompile things and I’ve not worked out how what and where to build things yet…