Community
OpenEnergyMonitor

OpenEnergyMonitor Community

OpenEVSE and EMONCMS not connecting

Tags: #<Tag:0x00007f68102a2db0>

Just built my OpenEVSE system and cannot connect to Emoncms.
The only difference from the normal kit is I’m using the ESP-32 Ethernet gateway module as final installation will be on the margins of my WiFi coverage.
The systems works perfectly from the local host.
I have followed all of the instructions that I can find on connecting to either server (Emoncms.org and data.openevse.com/emoncms) but my OpenEVSE interface is slightly different from the tutorials. (V3.3.2).
Need a set of fresh eyes to figure out what I’m doing incorrectly.



Any help appreciated.

Hi,

this is what mine looks like, the key you get from your emoncms.org account settings and need to be the write one.

John

John, Thanks for taking the time to reply. I have tried as you suggested but still cannot connect. Here are the steps that I have taken:
1 I have an account on emoncms.org with sufficient credit for posting feeds.
2 Emoncms setup page I have created an input with the default
OpenEVSE device configuration. I have initialized and saved this configuration.
3 I have copied the Write APIKey from ‘My Profile’ and pasted it into the ‘Emoncms write-apikey’ field in the OpenEVSE local portal.
I have tried using both the HTTP and HTTPS settings.
I have also tried using the ‘Device Key’ from the ‘Configure Device’ page.
Still not connecting.

Hi,

I cannot remember now but I d not remember having to create the input on emoncms that was created automatically when they connected. Not sure this would make any difference to them connecting though. Sorry at this point I have no other ideas. I work in IT and at this point I would move to wireshark but that is getting very technical. Not that I think it will make any difference but what versions of software/firmware are you running? My system is this

John

It looks like you are doing everything correctly to post data to emoncms.org. Creating the device in Emoncms is not needed, the Input will get created automatically when the units starts posting. See the video guide:

Are the other features on the OpenEVSE WiFi working ok? Can you stop and start a charge from the interface? What version WiFi firmware are you running?

Can you think of any reason why the OpenEVSE may not be able to access the internet? Do have any restrictive router settings they may be blocking access? VPN?

Well…I discovered that it’s something in my router that’s blocking communication.
I connected the OpenEVSE unit via a mobile hotspot and it connected instantly. Thank you Glyn for the suggestion.
Now to see whats blocking the communication.
Cyril

Sorted. It was the DNS server setting. Changed DNS and all working correctly.

1 Like

Hi,

very interesting, did you have issues connecting to emcms.org from any other devices?
Glad you got it sorted.

John

No john. I was able to connect with any pc or mobile device from the home LAN. Just the OpenEvse module failed to connect to Emoncms. Cyril