Community
OpenEnergyMonitor

OpenEnergyMonitor Community

No AC/AC adaptator detection on emontx

Dear all;
I buy 2 emontx (emonTx V3 - Electricity Monitoring Transmitter ) on 2017. I recently test theme. Ony is tested in Burkina Faso (West africa). This one work well. The second one tested in France don’t show voltage. It seems it doest not detect the AC voltage. I have tried : 1. AC/AC adaptator without mini-usb power supply : Seems to not working. 2. With mini-usb power supply only, seems to work.3. AC/AC adaptator with mini-usb power supply : do not know what happens.
Any comments and advice are welcome
Best regards
Arouna

Welcome, @photoacoustic to the forum.

I do not completely understand what your problem is. The emonTx V3.4 (please confirm this is the version you have - a Version 3.2 was also produced for a short time) can be powered from one of two sources:

  1. From a 5 V USB supply. In this case, the jumper link on the circuit board – JP2 on the edge of the board between the screw terminals and the USB connector – should be removed and the a.c input from the ac-ac adapter is used only to measure the mains a.c. voltage.
  2. From the a.c. adapter. In this case, the jumper link on the circuit board MUST be present. The a.c input from the ac-ac adapter is used both to power the emonTx and to measure the mains a.c. voltage. The mains voltage must be high enough to give enough power - therefore if you use the wrong a.c. adapter, it will not work. In France, you should use the AC-AC voltage sensor (Euro plug) - Shop | OpenEnergyMonitor

In both cases, you should be able to read the a.c. voltage using the emonTx.

If the emonTx does not work using only the ac adapter for power, then (1) check that the jumper link JP2 is fitted correctly, (2) check the voltage from the a.c. adapter - you should read approximately 11 V with nothing (or only the emonTx) connected.

More information: EmonTx V3.4 - OpenEnergyMonitor Wiki

JP2 is the black component on the left-hand edge of the circuit board in this picture:

Dear Robert
Thanks for your comments. I have version EmonTx V3.4.1. The jumper JP2 is not present (open). I will put a jumper and let you know.
Thanks again

1 Like

It is still not working. It seems I have a broken device!!

What have you tried?

What are you able to test?

Do you have a programmer?

If you have, or can borrow, a multimeter, these are the first things to check:

If you are using the USB power supply, do you read approx 5 V d.c between terminals 3 (GND) and 1 (5 V) on the screw connector?

If you are using only the a.c. adapter, do you measure approx 11.5 V a.c. on the adapter’s plug?

Do you - whichever adapter you use - measure approx 3.3 V d.c. between terminals 3 (GND) and 2 (3.3 V) on the screw connector.?

Do you see a red flash from the LED next to the a.c. socket?