New install, no inputs and no led flashing on RFM69Pi

Hi, after my last install failed due to an expired usb flash drive, I have now got a new drive and I have installed the latest version. I have modified the installation to startup from a sd card, then switch to a usb flash drive. It all seems to have installed/setup ok but I don’t have any inputs, and the led on the emonRFM* is not flashing. It’s not immediately obvious to to me how I am supposed to create/setup the feeds.

Sorry to hear, could I ask from some more info. Are you setting up using the latest pre-built SD card image?

See user guide for how to setup feeds:

When you say emon RFM do you mean RFM69Pi?

Hi, thanks for the reply. I am using emonSD-03May16, but I have altered the cmdline.txt file in the boot partition to point to the root filesystem on /dev/sda2 instead of /dev/mmcblk0p2 on the sd card. I have also edited ~/emonpi/fstab to point to the partitions on the flash drive instead of the sd card.

I have looked at the Input API helper page, and I have selected: http://192.168.1.102/emoncms/input/post.json?node=1&csv=100,200,300 This gives me a screen with ‘ok’ in the top left corner. I then go to the inputs screen and I have three lines but none get updated. I have three nodes here, one for power+temperature+humidity, and the other two are just for temperature+humidity.

I have done a little research since the first post and I have a RFM12Pi.

Posting the above should result from int the following Input:

You will need to log this Input to Feed if you want it recorded.

Do you mean you see these inputs in Emoncms? Could you post a screen grab of your inputs page?

The Red LED on the RFM69Pi should flash every 10s if you have an emonTx powered up in the vicinity. The LED on the front of the emonTx should also flash every 10s. See emonTx user guide: + Add Additional emonTx - Guide | OpenEnergyMonitor

Sorry, I think I’m confusing things. I have three nodes that should show up in the inputs screen, however I only get what is posted below. As you can see, they are not getting updated.

I have the led flashing on the emonTX, but not on the RFM69pi.

Oh ok, so emoncms is working fine. You can post data using the API. What seems to not be working is the RFM69Pi. You should have a number of inputs from emonTx, similar to this:

If you don’t then if must mean your RFM69Pi is faulty. Assuming you emonTx is on the same frequency and network group (433Mhx and 210 group default). Which it should be, unless you specified 868 or manually changed the group. Please email [email protected] with your order number and we will send you a replacement RFM69Pi to test. Sorry for the hassle

How do you change the frequency? On my original setup there was an option to change it. On this latest version I cannot seem to find that option.

You can set it in emonhub.conf

See setup > emonhub in local emoncms

Can you post contents of your. EmonHub.log file viewable from the same emonhub section in local emoncms

Hi Glyn, I have it working! :joy: I had to set the com_baud rate to 9600 in the emonhub editor. I must have ancient hardware lol.

Thanks for all your assistance.

1 Like