Marking a topic as solved

A useful feature of Discourse (with the correct plug in installed) allows topics to be marked as solved. A trusted user (moderator or trusted level 3 user) can choose a particular post on a thread as the solution to the question posted by the topic. See example:

Hers is the topic I marked as solved to test

Nice… Just noticed that posting a link to another thread results in an embedded snippet of the linked to thread. See above.

1 Like

The embedded snippet is a fantastic feature although there does seem to be a flaw. If you expand the snippet you will see the correct version of the embedded text.

“Just occurred to me the backslash is probably the escape character, escaping the hash so that # (hash escaped by backslash) doesn’t get seen as (unescaped hash will show this comment as h1 text) so I wonder if the escape char can also be escaped using [escaped backslash missing]# (double backslash hash) and if so would it also work within text eg blah blah blah [escaped backslash missing]# (double backslash hash) I also wondered if quoted backslashes were affected eg “blah blah blah [escaped backslash missing]# (double backslash hash)” So a backslash can escape ot”

Perhaps this difference between preview and expanded snippet needs highlighting to discourse as an issue?

It is however a good example of why threads should rarely be marked as solved!

Also this plugin seems to need to highlight one single post and one single user as the fix and fixer, this is very rarely the case and could be not only misleading if not fully fixed, but distracting from other potential fixes not marked as solved, plus cause confusion when the fix is spread across several posts and potentially bad feeling when it is a group effort or credit goes to the wrong user.

I had thought the use of solved tags had itself been marked solved when we all discussed this via email but it would seem that isn’t the case and the hypothetical solved tag needs to be removed …


For example

May have found another minor flaw with the snippets, this second link was done after I went back and corrected my typo and removed “TEST POST”. You can see the previous one has retained the original text in the snippet despite it being correct if you expand it. The preview is basically a snap shot of the post at that time and the expanded view is current.

EDIT - well it would seem the preview will not shake the original text, for this last link I went back to the already corrected post and got a fresh link, when applied here it shows the previously uncorrected text in the preview. I am only guessing here that maybe it’s using archive versions or something so the actual content may change at some point and render these comments (or me) apparently insane.

Thanks for your extensive testing. I reckon the snippet issue is probably an internal cache issue. Let’s see if it changes in a bit. Well spotted, I guess there is a possibility this could be a Discourse bug