M-bus to Kamstrup 403 not working

Just installed my Kamstrup 403.

Not seeing modbus responses.

Checked voltage and its 30.5VDC across MBUS terminals.

Any ideas please?

I Have adjusted the DC-DC power supply to 24V.

Still not reading back.

Your 403 uses M-Bus (Meter Bus) which is quite different from Modbus.
I’m not familiar with M-Bus, so unfortunately I can’t help. But I do know that’s it’s not
the same thing as Modbus. Perhaps someone versed in M-Bus can help.

Edit - I see that a Modbus module for the 403 is available.
If you have the Modbus module, I might be able to help.


Thanks, my mistake.

It is M-Bus.

I have also just set the “Primary Address” on the Kamstrup to 100 to match the default in the arduino heatpump firmware.

Got excited as it was not set to 100 in the Kamstrup when i found the menu, But sadly still not talking…

I edited the title of the thread to reflect that.

Hello @jbetech

Can you check the baud of the Kamstrup meter from the LCD display? Does it match the baud rate set in the firmware? The DC-DC Power supply should read ~34V

Hi @TrystanLea

Thanks for jumping in! I hope you would :smiley:

I cant see Baud on the meter display and sounds like it auto detects:

Communication speed
The modules support 300, 2400, 9600 and 19200 baud communication speed and automatically detect the communication speed used by the M-Bus master.

Is it 34 vdc? I set it to 24 when reading the install guide:

Troubleshooting: If the kamstrup meter data does not appear straight away, wait several minutes for the reader to rescan. The voltage across the MBUS reader terminals should be close to 24V.


Thanks for spotting the typo @jbetech the voltage should be 34V. I’ve amended the guide, let me know if it starts reading.

1 Like