Low CT readings for power consumption

I have just reinstated my Emonpi for monitoring solar PV (3 phase, using optical sensor on dedicated generation meter) and household power consumption (single phase using CT sensor plugged into CT1).
When I last used the Emonpi a few months ago I recall everything seemed to be working as it should however now I am getting low power consumption figures. To test this I have tried turning on a load of over 1kW (eg kettle, electric oven, immersion heater, PHEV car charger). When I do this the power consumption feed from the CT1 input increases by only a few hundred watts.
Any suggestions?

Have you put the CT on the correct cable?
Is the CT closed up correctly?
Did you restart the emonPi after you’d connected the CT & a.c. adapter?

Thabks Robert.
I have checked and checkd again, and rebooted the Emonpi after making sure the cables are correctly connected but I still have the same issue. It is almost as if the consumption figures are out by a factor of 10.

One more: Has the C.T. core or the cable got damaged? If that’s OK, then hopefully that’s disposed of the silly faults.

Has emonhub.conf got the correct scale factors in it? The emonPi is Node 5, and the first 3 numbers in “scales =” ought to be 1 (i.e. you’re not really scaling the powers power1, power2 and the sum power1pluspower2).
Are you using an a.c. adapter - what voltage is being reported?
Does CT2 input behave in the same way?

Hi Robert.
There doesn’t appear to be any damage to the CT cable and core.
The CT2 behaves in the same way as the CT1 input.
Scale factors for CT1 and CT2 are both set to 1. (see screen shot).
The voltage sensor is reading around 226V. (see screen shot)

Is 226 V reasonable? You don’t say where you are, it’s a bit low for the UK so I presume you’re not in the UK.

I have assumed you have the ‘shop’ c.t (YHDC SCT-013-000). Is that correct?

Do you have a multimeter that can read a.c. current down to below 50 mA? If you have, you could check the c.t. directly by connecting your meter to tip and sleeve of the c.t’s plug, and you should see 0.5 mA per amp of primary current.

Hi Robert

I’m in Northern Ireland, I don’t know if that’s reasonable. I am in a rural area and the local network isn’t renowned.


The nominal UK voltage is indeed 230 V ±10%, according to EU harmonization, but historically it was 240 V, and as far as I know, the voltage remains centred on 240 V due to the practical difficulties of changing large numbers of final distribution transformers. So if the 226 V is correct, that largely rules out a problem with the voltage reference that the emon part of the emonPi uses for the measurement, but it still doesn’t account for a factor of 10 (on power, = √10 on both voltage & current).

Without an independent means of tracking down the source of the error, I’m running out of ideas.

Thanks Robert. I feared there wouldn’t be a straightforward solution!
I will try to figure out if a scale factor is involved and what it should
be to bring my readings up to roughly where they should be by looking at my
daily consumption figures derived from metered export and import.

From that, I take it that you have no means of independently checking any currents etc. It’s unlikely that both emonPi inputs have the same fault, I think the only real possibility left is the c.t. is faulty, hence to confirm that, I wanted you to check it directly without involving the emonPi.

Are you able to borrow a multimeter that would measure the c.t’s output directly?

If it is faulty, I wouldn’t like to say whether the output would be linear or anything, so everything you do with it could be wrong.

Yes Robert I have a multimeter. How should I go about measuring the CT
output with it?
I appreciate your comments about the non-linearity - obviously I would only
take the route of altering the scale factor if I could show this would
work. I would have thought that if for example the daily consumption
derived from my meters exceeded that recorded from the Emonpi by a factor
of 10 reliably over several days that would show the relationship is
linear. You would obviously know better then me how likely or unlikely that
is given the parameters of the CT sensor and Emoncms!

So a 1 kW heater should give you 2.17 mA a.c.
You should also measure about 100 Ω between tip and sleeve (with the c.t. off its cable and no current flowing, of course).

Hi Robert,

Unfortunately my multimeter isn’t that sensitive for AC.

Right now - when there will be very little power consumption, but some -
the “use” on my solar app is showing 0W so I think that shows my factor
of 10 theory is wrong.

I’m installing a wind turbine over the summer so when there’s a spark
here I’ll get him to check the operation of the CT for me.

Thanks for your help.


What resistance do you see for the secondary winding?

How would I measure that?
Incidentally it is indeed the shop CT. Sorry I don’t seem to have read some of your replies fully.


With your multimeter!

Sorry to be so dim but do you mean I measure the resistance across the coil
in the CT?

You’re measuring the resistance of the secondary winding, yes, but the easiest place to get to it is at the jack plug - no need to take the c.t. apart.

Anything wildly different suggests a fault in the cable or the c.t. That’s rare, but not impossible.
You are sure it’s on the correct (single core) cable, and that cable is not being bypassed by another, which is possible if your installation is faulty?

Thanks again Robert, my apologies for missing the directions on measuring
the resistance!
I’ll see what I come up with.
The CT is attached to the same cable I had it on last year which gave
sensible readings, and nothing in the installation has changed.
I’ll let you know how I get on.

Experience has taught me that, once you’ve exhausted all the sensible reasons, you look at all the ones it cannot possibly be, and all the ones that are so silly that it can’t be that either, and all the ones that are so obvious you would surely have noticed before.