Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Login to Emonpi on iOS 12.5.4 Safari

Just moved house and now have Solar and battery. Thanks to all who have contributed great developments since I last was on forum in 2017: I’m looking forward to finding out more about the changes. Prior to move, I was running a 2016 build which was perfectly suited to my monitoring needs, so I took a “no update” stance". However, I have now flashed the current stable release (low-write 10.7.7) to a 16GB card and installed on the model 2Pi based EmonPi. All went well, other than my inability to design processing steps for the new setup, and I now have a good set of data from the feeds and from a Powerwall (thanks @johnbanks).

All is well via Chrome and Firefox on PC, but logon to the local network emonpi via Safari on 12.5.4 iOS fails: this old iPad has been fine to date with accessing the older Emoncms. The logon probably does not fail but returns the logon screen rather than the feed list (url is emonpi/feed/list). If I type the wrong password I get told so: there is no error with the correct password. On one occassion I got read only access to emoncms via scanning the QR code after the correct password had been applied (and the webpage emonpi/feed/list was active but showing the logon screen). I cannot duplicate this access having repeatedly cleared cache. On iOS 14.7.1, I initially had the same logon symptons (returned to logon screen). Scanning the QR code prompted for the logon credentials and, after giving then, have been able to access read/write all the EmonCMS webpages.

I take it that the old iOS is the issue, but is there any way to overcome this? EmonCMS My Solar helped drive my lifestyle and I was hoping My Solar and Battery would do the same.

Thanks again for all the development efforts by all.

Andy

Hi Andy,

Have you tried searching the forum for safari?

Several threads pop up in the result list.

Hello Bill. No, I tried “login failure” and the like. Now I have tried “Safari” as per your suggestion, the symptons sound the same as reported in https://community.openenergymonitor.org/t/safari-issue-with-emoncms-10-2-7/17739 back in 2013. I do not have access to a desktop mac to follow the console errors on the ipad, but a Javascript issue may possibly be the root issue I guess. Thanks for responding.