Length required error message when posting data to emoncms local

Hi,
Posting data from ICC Solar app to emoncms.org witch is OK
but posting to emoncms local failing with return message “Length Required”
When I test posting via api input/post links working fine.
Any idea someone?
Thanx.
Martin.

Hi Martin

What emoncms version?
Any examples of a failed request?
Any clues at all?
Has it ever worked correctly? Is this something new you are trying?

[edit]

A quick search of the emoncms source code doesn’t turn up anything for “Length Required” is that the exact message?

Hi Paul,

It is new installation.
Version 9.8.10 / 2017.08.17
Newer worked for ICC Solar (http://iccsoftware.co.za)
interesting is that input api links are work correctly …
and also when I post from ICC Solar to emoncms.org work OK
Don’t understand situation.

That app have no log, only simple in app field witch is return OK or error message. For me only Length Required.
If you enter wrong api key you’ll get Authentication Required. So very simple.

Is there any method in emoncms to see what is going on?