Killed My Box With v9.8.27 - Help Please

Updated my factory built unit from v9.8.25 to v9.8.27 and alas it no longer works :frowning:

After a reboot from the web interface in the log all you get is

2017-12-28 19:38:59.175|ERROR|phpmqtt_input.php|exception 'Mosquitto\Exception' in /var/www/emoncms/scripts/phpmqtt_input.php:125
Stack trace:
#0 /var/www/emoncms/scripts/phpmqtt_input.php(125): Mosquitto\Client->connect('localhost', 1883, 5)
#1 {main}
2017-12-28 19:38:59.285|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 19:39:05.001|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 19:39:05.002|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0
2017-12-28 19:39:13.605|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 19:39:13.624|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0
2017-12-28 19:48:19.605|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 19:48:19.623|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0

The LCD says Error MQTT Not Connected and I logged in using putty and did what a google search suggested was a basic test which told me nothing other than the mqtt service seems to be running.

[email protected](ro):~$ sudo systemctl status mqtt_input.service
● mqtt_input.service - Emoncms MQTT Input Script
   Loaded: loaded (/etc/systemd/system/mqtt_input.service; enabled)
   Active: active (running) since Thu 2017-12-28 19:39:11 UTC; 8min ago
     Docs: https://github.com/emoncms/emoncms/blob/master/docs/RaspberryPi/MQTT.md
 Main PID: 2060 (php)
   CGroup: /system.slice/mqtt_input.service
           └─2060 /usr/bin/php /var/www/emoncms/scripts/phpmqtt_input.php

Dec 28 19:39:11 emonpi systemd[1]: Started Emoncms MQTT Input Script.
[email protected](ro):~$ sudo service mqtt_input stop
[email protected](ro):~$ sudo service mqtt_input start
[email protected](ro):~$

Web interface info

Emoncms Version low-write 9.8.27 | 2017.12.21
Modules Administration | App v1.1.0 | Backup v1.1.0 | EmonHub Config v1.0.0 | Dashboard v1.1.1 | EventProcesses | Feed | Graph v1.1.0 | Input | postprocess | CoreProcess | Schedule | setup | Time | User | Visualisation | WiFi v1.0.0
Buffer 0 feed points pending write
Writer Daemon is running with sleep 60s
Server OS Linux 4.4.26-v7+
Host emonpi emonpi (127.0.1.1)
Date 2017-12-28 19:48:28 UTC
Uptime 19:48:28 up 9 min, 1 user, load average: 0.21, 0.20, 0.16

Any ideas please?

Fixed :slight_smile:

It needed an EmonBase Update and now works again.

It does still give these few lines in emoncms.log

2017-12-28 20:48:05.002|ERROR|phpmqtt_input.php|exception 'Mosquitto\Exception' in /var/www/emoncms/scripts/phpmqtt_input.php:125
Stack trace:
#0 /var/www/emoncms/scripts/phpmqtt_input.php(125): Mosquitto\Client->connect('localhost', 1883, 5)
#1 {main}
2017-12-28 20:48:05.090|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 20:48:11.002|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 20:48:11.003|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0
2017-12-28 20:48:20.699|WARN|phpmqtt_input.php|Not connected, retrying connection
2017-12-28 20:48:20.717|WARN|phpmqtt_input.php|Connecting to MQTT server: Connection Accepted.: code: 0

Are these anything to worry about?

Many thanks