Jessie Install Update (Solved)

Hi. My Jessie install has been running for 2 years now. I did an update using git as stated

“cd /var/www/emoncms && git pull”

I get this output and nothing updated.

"*** Please tell me who you are.

Run

git config --global user.email “[email protected]
git config --global user.name “Your Name”

to set your account’s default identity.
Omit --global to set the identity only in this repository.

fatal: empty ident name (for [email protected]) not allowed
"

I am still on version 9.8.7. I see 9.8.28 is the latest. Can I just down load and copy the new files in the same place and replace the settings.php file ?

Never mind. I just had to add sudo. All is working now.

You shouldn’t need to add sudo to git pull emoncms.
The emoncms folder should be owned by pi.

Paul

I spoke to soon. My MultiGraph charts are not working. now.

OK so that was a Chrome cache problem. All good now.
I also changed the owner / group to pi as well.

1 Like