OpenEnergyMonitor Community

iOS app released!

Tags: #<Tag:0x00007f1bd5c5ab28> #<Tag:0x00007f1bd5c5aa60> #<Tag:0x00007f1bd5c5a920> #<Tag:0x00007f1bd5c5a858> #<Tag:0x00007f1bd5c5a790>

Today I released the iOS app to the app store!

You can check it out here:
(Note: It may take a little while for Apple’s servers to flush their caches - really annoying but happens every time an app gets released or updated!)

I’ll keep doing the beta program for future updates.

Thanks everyone for your help during the development of this. And I’m excited to see it get built upon in the future.

1 Like

found and installed (shows version12) and install didn’t kill the configuration

looks great to me! Thank you Matt!!

Saw the new version was named EmonCMSiOS. was EmonCMS already taken?

Oh balls I meant to change that! I will do for the next version.

Hi, many thanks for this, looks good. I do have a small issue, I’ve just added a feed for power to kWh to my setup and corrected my power app. However, now I get “Failed to connect”, both of the feeds are set to public. It works when I set the kWh to a different feed temporarily (e.g. to the main power feed).

I don’t know how to investigate further, so appreciate any help.


Gah, how annoying.

Can you send me logs from the app by going to settings and tapping send feedback please? Make sure you go into the MyElectric app first and get a failed to connect before doing the feedback.

Had to setup a temp email account to send that. Although the log is quite clear. “Start of day data has no data points”. Presumably this is because it’s a new feed that I have just created? And I should just wait until tomorrow?

Ah yes it’ll be that indeed!

I wanted to make the errors more clear, but there’s a lot of things that can cause errors. Maybe this one is a good one to have a specific case for.

1 Like

Just to confirm that it all works now :slight_smile:

Hallo, thanks for the APP, will be very useful for me, I made the setting works correctly ,I can see the feeds nut what I configure the APPS once selected feeds it cannot connect to emoncms, always gives me red bar ERROR And still loading data.

If I may give some suggestion will be very appreciated if will be possible to see more than one feed together in the same graph.

Morning All.

I installed the iOS app yesterday. I didn’t know it was here, I just found the link on the emoncms homepage and had a go. I have a couple of questions.

  • Is there a technical reason it will only work on iOS 10? This is a real disappointment to me as it means it doesn’t work on 3 out of 4 of our devices. (Ipad 1, 2 and iPhone 4s). Its a shame as the WebApp works on all of them still, even the ipad 1 which is still functional but struggles to find a purpose now.

  • I can only see the ‘MyElectric’ app. Is there a plan to add a ‘MySolar’ app as well as there is in the Website?

  • Will it be possible to add our own configurations? I would like an ‘app’ to show internal and external temp and humidity but currently its only geared towards kwh.


Actually I’ve also noticed my kwh_d feed in the app is not showing the same value as it is in emoncms.

In emoncms its showing 3.1 kWh, in the app its only showing 0.02kWh.

Is it only showing the total for the period the graph shows, or for the time the app has been running?

Yup! Currently the aim was to replicate the Android app. But solar app is on the list to do.

There is a technical reason, yep. I used some APIs that were only available on iOS 10. However, I’ve already worked around those and in the next update you will be able to use it on iOS 9.3.

This is going to be much more tricky to implement and “get right”. I initially had envisaged this would be the main thing the app did, but then I realised it would take a lot of work to do this. It may go that way in the future, but I don’t see it happening soon, especially if it’s still just me on it.

Interesting. What time zone are you in? Is it the same as your EmonCMS instance is set to? It shows the total for “today” in the time zone of your device.

1 Like

That’s good news! my ipad2 is limited to iOS 9.3.


Good news! The iPad 2 lives on…