Installing homie-ota. not able to run service. Help please!

I’ve just flashed emonSD-07Nov16 RELEASE on my Rasperry Pi 2.

I would like to integrate homie-ota a OTA “server” for Homie-ESP8266 framework for ESP8266 modules , I tried to follow the install step by step instructions but checking the log with

journalctl -f -u [email protected]

I obtain this output

    Dec 08 21:26:12 emonpi python[810]: IOError: [Errno 30] Read-only file system: '/home/hota/homie-ota/homie-ota/homie-ota.log'
    Dec 08 21:26:12 emonpi systemd[1]: [email protected]: main process exited, code=exited, status=1/FAILURE
    Dec 08 21:26:12 emonpi systemd[1]: Unit [email protected] entered failed state.

the “Read-only file system” on the first line :…I think the problem is due to the fact that the system user hota is trying to write in the readonly partition.
Thank you

you will need to move /home/hota/ to /home/pi/data/hota/ then symlink to allow homie to write to the log file.

/home/pi/data/ is mounted as a R/W partition on the emonPi. Alternatively, you could move the logfile to /var/log/

Hi Glyn
thank you for replying.

I’m sure I’m doing something wrong (I’m sorry but I have a very little experience with Linux).
I’ve moved
sudo mv home/hota/ home/pi/data/hota

then Rebooted.

Now no more read only error :slight_smile:
but :frowning: it fails

Dec 09 09:48:35 emonpi systemd[1]: Starting Homie OTA...
Dec 09 09:48:35 emonpi systemd[1]: Started Homie OTA.
Dec 09 09:48:37 emonpi systemd[1]: [email protected]: main process exited, code=exited, status=2/INVALIDARGUMENT
Dec 09 09:48:37 emonpi systemd[1]: Unit [email protected] entered failed state

and the status is

[email protected](ro):~$ sudo systemctl status [email protected][email protected] - Homie OTA
               Loaded: loaded (/lib/systemd/system/[email protected]; enabled)
               Active: failed (Result: exit-code) since Fri 2016-12-09 09:48:37 UTC; 1min 42s ago
              Process: 811 ExecStart=/home/pi/data/hota/hota/.venvs/homie-ota/bin/python /home/pi/data/hota/homie-ota/homie-ota/homie-ota.py (code=exited, status=2)
             Main PID: 811 (code=exited, status=2)

at the same time MQTT server connection refused (from homie-ota.log):
2016-12-09 11:22:12,518 ERROR Cannot connect to MQTT broker at localhost:1883: [Errno 111] Connection refused

But if I manually start the service with
sudo systemctl start [email protected]
It’s ok, infact checking the status the output is

[email protected](ro):~$ sudo systemctl status [email protected][email protected] - Homie OTA
   Loaded: loaded (/lib/systemd/system/[email protected]; enabled)
   Active: active (running) since Fri 2016-12-09 09:54:16 UTC; 3s ago
 Main PID: 4466 (python)
   CGroup: /system.slice/system-homie\x2dota.slice/[email protected]
           └─4466 /home/pi/data/hota/hota/.venvs/homie-ota/bin/python /home/pi/data/hota/homie-ota/homie-ota/homie-ota.py