Inputs wont load, and some feeds not working properly

Hi all.
I have a WEIRD problem that, for the life of me, i cannot work out.

My input list wont load. Im not 100% sure exactly when the issue started happening, but when i upgraded from 10.1 to 10.7 i had a myriad of issues so it is likely related to that.

When I try and load the inputs, the page constantly tries to load list.json, and gets stuck in a loop. They are all HTTP 200 responses.

list.json loads fine when i load it manually, and it validates using a lint checker.

Theres nothing in either the apache error log, or the emoncms error log.

Should i literally just blow away emoncms and start again ?
Losing data would be … dissapointing, but not life changing.

There are some feeds not working, but i believe they might just need to be blown away and re-created, but if i cant load inputs to configure them, thats going to be difficult!

Emoncms Core v10.7.0 | App v2.3.0 | Dashboard v2.1.2 | Device v2.1.0 | Graph v2.1.1

Comparing to my system, I’m guessing those are requests for device/list.json, which are meant to be fetched every 5 seconds or so.

There should be another file requested at the same time, input/list.json, which doesn’t appear in your screenshot (it would be much larger, I expect).

Check the browser console - any errors in there?

Have you tried clearing your browser cache? This can sometimes be the source of issues when upgrading version.

Ahh. i didnt pick up on the different URL.

However, hitting device/list.json gives an error.

**Fatal error** : Uncaught Error: Call to a member function fetch_object() on bool in /var/www/emoncms/Modules/device/device_model.php:274 
Stack trace: 
#0 /var/www/emoncms/Modules/device/device_model.php(235): Device->load_list_to_redis(1) 
#1 /var/www/emoncms/Modules/device/device_model.php(225): Device->get_list_redis(1) 
#2 /var/www/emoncms/Modules/device/device_controller.php(65): Device->get_list(1) 
#3 /var/www/emoncms/core.php(65): device_controller() 
#4 /var/www/emoncms/index.php(240): controller('device') 
#5 {main} thrown in **/var/www/emoncms/Modules/device/device_model.php** 

on line **274**

So … the line its failing on is running this query:

SELECT `id`,`userid`,`nodeid`,`name`,`description`,`type`,`devicekey` FROM device WHERE userid = $userid


How did you update Emoncms? Did the database get updated at the same time, or do you need to run that step manually?


Wow. Its the simple things isnt it.
Im so very sure i ran that, but apparently not!

Thanks @Timbones, that seems to have also fixed my intermittent graph problem too!


Good that you’ve got it working. Starting from scratch is never fun.