Community
OpenEnergyMonitor

Community

Input node keys seem to have moved after reboot

emonpi
Tags: #<Tag:0x00007f1be63c9a48>

(Jon Summers) #1

Hi. I’m using an older version 9.8.28 which was working perfectly until I changed to a fixed IP address. After a reboot, it now responds on the new IP address but the configured keys I used in the node (emontx4) failed to receive any updates. Scrolling down the page I can see emontx4 has grown in size - I believe - and the realtime updates are going into the new, added on, keys.

Rather than just stab about and make things worse as I usually do (learning!) this time I thought I would ask for some advice first.

Many thanks.


Emoncms.org posting problem
(Paul) #2

Wise move :slight_smile:

We have seen these symptoms many times and more often than not, users start shifting their process lists to the new inputs. That isn’t necessary, if you just delete the duplicate set of inputs, they are the lower ones, currently being updated. The original inputs will start updating again.

Some form of “glitch” has caused a new set of inputs to be auto created, presumably because emoncms didn’t recognize them as existing. I cannot say what caused the “glitch” but once that occurs emoncms only updates the newest set (last found when searching), just deleting the 2nd set will make the original set the “last found” and all will be well (unless of course you are unlucky enough for the “glitch” to reoccur).

So just delete the “emontx4 power1” input that’s got a green update time, and each of the “emontx4” inputs below that, be careful to only delete the 2nd set as the originals will turn green as they start updating again.


(Jon Summers) #3

Many thanks Paul, that fixed it. I almost tried that but I was going to start at the end of the list with rssi - I wonder if that would have worked?!

Many thanks again.

Jon


(Jon Summers) #4

Deleted as this post should not have been at the end of this thread.