|index.php|Invalid API key

HEllo Everyone

Just getting going with EMON, I have a Pi loaded for local logging, and just got a EmonTX V3. At the minute I can’t see any feeds. I have checked on the PI with minicom and can see data from the RFM69Pi_433

When I check in Administration the last lines in /var/log/emoncms.log shows
2017-05-10 10:19:48.476|ERROR|index.php|Invalid API key

where do I change the API key for the index.php.

Hi David

The message is saying the index.php has identified the api key is invalid, there is no apikey for the index.php itself. Each account has 2 apikeys, one readonly and one readwrite. When you make an api call eg posting data, the apikey included in that api call is checked against the database to determine the apikey is valid and if so which account it is for and which type (RO or RW) it is.

Basically the requests you are using do not contain a valid apikey, for posting data the valid apikey is the readwrite apikey for the target user account.

Is this a bespoke setup or is this an emonSD?

If it’s the latter it is just a case of ensuring your emoncms readwrite apikey is correctly added to the emonhub.conf, otherwise you would need to tell us more about the route the data takes from the emonTx to emoncms.

Hi Paul

Sorry for delay in replying now away in carribean with work and lumpy
internet . Thanks for your message. In the end I started again with
emonpi Jessie image, the second time I managed to get it sort of working,
but now seem to have a problem with folder permissions with the rw ro.
I moved everything over to an external bed to enable low write. Not sure
if I have missed something somewhere.