Import from USB drive: problems upgrading to emonSD-24Jul20

Upgrading from emonSD-17Oct19 to emonSD-24Jul20 and following the instructions at Update & Upgrade - Guide | OpenEnergyMonitor, I have 2 questions:

  1. Step 2 Initial Boot, item 3 “Insert the new SD card…wait, wait, wait”. What is the indication that it has completed? Is it the change in the displayed LCD text from Updating… to Ethernet: YES?

  2. The restore from USB drive using the old SD card failed with the message

Can’t connect to database, please verify credentials/configuration in settings.ini
Error message: 'Unknown database ‘emoncms’

This sounds similar to the issue @stuart had [Import from USB drive - deleted emoncms database] but where do I find the log file to find out what has happened? I have left the system running and can ssh in.

If you can ssh in, check the CPU use has dropped right back - use htop to verify.

@TrystanLea any suggestions?

I’ve experienced the same error message after trying “Import from USB drive” on a new installation of emonSD-24Jul20:

  1. I installed the emonSD-24Jul20 image on a new SD card
  2. Went thru the update process, everything worked fine
  3. Accessed emon using web browser to its local IP address
  4. Successfully created a new user account and accessed Admin and Backup
  5. Put the old SD card with 17Oct19 image into a USB card reader plugged into my Pi
  6. Clicked “Import from USB”
  7. Then got some error messages in the emon window that seemed to indicate the USB drive could not be found, but before I could read the messages or take a screenshot, the emon window disappeared and my browser showed

I have ssh access to the Pi and rebooted, but I get the same error whenever I try to access emon with the browser (using Chrome and Firefox).

Is there a way to repair or replace the settings.ini? Or another fix?

I’m back to running the 17Oct19 OS and can create a new compressed archive that I can import into the emonSD-24Jul20 OS once I can get back into the emon interface, so I don’t necessarily need to fix the USB reader problem.

@TrystanLea