How to stop Local Emoncms 'timeout'

I am not sure if ‘Timeout’ is the correct description but when I leave my EmonCMS page on my browser for more than a few minutes its loses contact with the underlying data, the basic EmonCms page is there but there is no data, I have to login again and reload the graph to see my data.

Is there a way to stop this timeout? I use a graph to monitor my power use and I refer to it many times per day, ideally I just want to login once.


Login should last longer than that, but I find I have to login a few times a day too. Not quite sure what’s causing that.

Anyway, if you mark you feeds and dashboards as Public, you’ll be able to see them without having to login at all.

I agree, it’s a nuisance.

@Timbones’ workaround isn’t really the solution, I think I’m mentioned this problem to @TrystanLea some time ago, but it’s been lost underneath the emonTx V4 development & everything associated.

Related: Frequent logouts?

Is this a dashboard page or a visualisation page?

Remember that feedwriter is set to sleep of 300s (5 mins) between writes to disk.



Should say I don’t notice this, but I don’t use dashboards.

Pretty much anything in my experience, though I haven’t had time to make a systematic study of what does and what doesn’t keep the browser ‘logged in’.

Interesting, I don’t see that at all. I tend to leave tabs open in browser(s) for days & weeks (just never turn the PC off, just the monitors) and never have any issue with being logged out on either Pi based or Virtual hosts.

I think it’s only Inputs pages that don’t time out. I’m fairly certain Graphs do, I haven’t noticed whether Feeds do or don’t, I rarely look at Visualisations so again no idea, I think Dashboards do.

That may be the clue. I’m talking about the browser tab being open, but not selected and actively updating on the screen. And this might mean it’s browser-dependent.
I’m also only talking about an emonPi.

Using a browser on my Linux computer, emonCMS on my local emonPi used to time out for me.

I found that when I tick the 'Remember me ’ box on the emonCMS login page before logging in, I don’t get any time outs - even the next day after the computer has been turned off and back on. Perhaps this might help? or is it just me? …

I think one thing that causes it (I find it frustrating too), is logging in from other devices, and I think that might now include viewing (ticking the Remember Me box doesn’t help me!)

Yes, I meant graphs - never notice an issue, but graphs do not update in realtime so pretty difficult to freeze :slight_smile:

Yes exactly that. various tabs open , inputs, feeds, graphs, but not dashboards and visualisations. I generally have tabs open in Vivaldi & Chrome on Windows.

On what page (or all)?

That is doing what it says on the tin then.

Do you run any ad blocking or cookie extensions? That might affect the operation of the system.

I thought we all knew that. What I mean by timing out on a graph is it doesn’t respond to any of the buttons, < > + - Reload nor the drop-down menu.

So unlike a dashboard or Inputs where (I think) the browser issues a periodic request for new data, there’s nothing incoming to the server and it times out, requiring a userID/password (and again I think this is what ticking “Remember me” supplies).

Not experienced that in any browser or any host.

As far as I remember, it was all pages I looked at.

I look at my local emonCMS using:

an Android phone chrome browser (not sure if it has an ad blocker)
a Raspberry Pi 400 with the chrome browser and uBlock Origin ad blocker
and probably various other things …

None time out after ticking ‘Remember me’…

I don’t know if the variations people see are anything to do with the versions of emonCMS and all the included software?

Brian, That I do not understand, my graphs timeout on any of the many browsers I use, including Brave, Chrome, Edge and Safari, this happens on my Mac and My Windows machine. How can it timeout on mine and not yours? are you using local EmonCms? what browser do you use?

All local;

Select ‘remember me’ before logging in. I use PiHole locally and ABP in Vivaldi.

Do you see this in the emoncms.log

2023-02-19 16:36:36.-495|INFO|rememberme_model.php|cookieIsValid
2023-02-19 16:36:36.-495|INFO|rememberme_model.php|findTriplet TRIPLET_FOUND

About once a second.

To be more specific, by this I mean that I am not logged out of emonCMS.
However I do have to re-enter my graph choices and redraw them …

No, I can just hit the refresh at the top, no matter how long I leave it unless the host is rebooted.


I think this is why it is so difficult to fix. There is a total lack of consistency in how it happens.

It could possibly be a network thing.

Does the device you are viewing from go into low power mode (suspend or hibernate)?

Well I have just tried:
on the graphs page: setting up a simple graph of Vrms for one week
going to the inputs page
going back to the graph page - the graph is blank
pressing the refresh

the graph is still blank

I’m not sure if this is the same thing …

The Pi400 screen is set to turn off after a while, but this didn’t happen during the above

Have you tried clearing the browser cache.

No, if your session had timed out, you would need to log in again. Did you?

Actually, the graphs page does not retain the information unless you save it!