Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Hardware fault?

Hi all,
I recently bought a EMonPi and set it up to monitor my solar and grid usage.
All seemed to be working well until the last few days where I noticed the if you touched the physical container there was a buzz/vibration off of it and it would print gibberish on the screen and crash.
I also saw a lot of the following in the logs
“Jun 13 14:09:32 emonpi kernel: [ 1025.841193] Under-voltage detected! (0x00050005)
Jun 13 14:09:36 emonpi kernel: [ 1030.001168] Voltage normalised (0x00000000)”
even though I using the supplied power supply.
I tried to look at monitors this morning but it was incredibly slow and didn’t connect most of the time.
I reset it but now the LCD is stuck at “Booting…” and even though I have ssh access into the box I couldn’t seem to figure out what was going wrong. The input values hadn’t bee updated in hours. I eventually did a factor reset and reconfigured it again. However I’m now no longer getting any input from the CT probes. I suspect that there’s a hardware fault as I’m getting the following in the emonhub.log

2021-06-13 13:52:23,364 INFO MainThread EmonHub emonHub (emon-pi variant) v2.2.6
2021-06-13 13:52:23,365 INFO MainThread Opening hub…
2021-06-13 13:52:25,372 WARNING MainThread Device communication error - check settings
2021-06-13 13:52:30,383 WARNING MainThread Setting emoncmsorg apikey: obscured
2021-06-13 14:17:31,988 INFO MainThread EmonHub emonHub (emon-pi variant) v2.2.6
2021-06-13 14:17:31,989 INFO MainThread Opening hub…
2021-06-13 14:17:33,993 WARNING MainThread Device communication error - check settings
2021-06-13 14:17:39,007 WARNING MainThread Setting emoncmsorg apikey: obscured

Any ideas on how to fix it ?

Welcome to the OEM forum, Noel.

We’ve seen this once before. @Gwil ? If I remember correctly, it was cured by earthing the case using one of the fixing screws.

There should already be a grounding wire connecting the screw nearest the golden SMA antenna connector on the aluminium case, with one of the ground pins on the underside of the blue emonPi PCB inside the enclosure.

Can you see anything on the screw like I described above? You should see a metal hoop between the metal fascia and the rest of the enclosure.

If it is present, the only way to check the other end of the cable is to open up the case with a Torx T20 screwdriver bit and see if it is connected to the ground (marked ‘GND’) pin on the PCB. I recommend removing the plastic fascia and sliding out the back plate (with the ‘CE’ mark) to take a look.

If you are still having issues and it can’t be resolved here, you can send me a PM or email the shop ([email protected]) with your order details and we will sort it out for you.

In December, the other user Steve ran a separate earth wire to his house earth. The PCB “ground” is floating until it is earthed via another connector, there is no earth via the power supply or the a.c. adapter.

That connection to the PCB might prevent problems with resetting/crashes, but it won’t remove the leakage current that Noel appears to be feeling when he touches the case.

Summary of my situation, now resolved

My initial problem was that I was getting PV readings at night.

I used to get a “buzz” when touching the case.

Only once when touching the case, the screen display corrupted; I rebooted. Did not reoccur.

I got Under Voltage messages on in logs.

I did not have any communication errors.

I tried
a) different CT clamp
b) different PSUs
c) running an earthing wire

a) made no difference

b) one PSU removed the “buzz” and made the PV read correctly at night. Several others didn’t.

c) the earth wire removed the “buzz” and made the PV read correctly at night.

In the end I removed the earth wire and went with the PSU that didn’t have the “buzz” as it was slightly higher voltage, so (from memory) I didn’t have the under voltage messages again.

I didn’t leave the earth wire in situ as I wasn’t exactly sure where to connect it to the emonpi.

Hope that helps.

1 Like

thanks Robert/Steve I’ll try that. Is there a way of checking that the hardware is working as the LCD screen is also having issues and even though I’ve done a factory reset I’m not seeing any sensor readings now. Do you know if there’s a way to read the raw data from the sensors? I suspect that they’re all related and the power/earth issue has caused some internal trouble.

There isn’t an easy way, but if you have a programmer, there’s a way, it involves disassembling your emonPi into its two main parts. It’s far simpler to check all the other things first.

Do you have important records that you need to keep? If not, as a first step I’d suggest reflashing the SD card.

Thanks Robert, I flashed the card and that seems to have fixed it.
The inputs are being reported and the UI is again working.

cheers
Noel