Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Getting your ip - nothing found

Hello - noob question of the day… EmonPi hardware installed and fired up. I can see an IP address on the EmonPi but can’t find it on the emoncms ‘find local device’. Apologies for being a bit dumb :wink:

I don’t know how this is supposed to work, as it is an internet address/domain image, however, if you have an EmonPi and the IP address appears in the LCD, just use that in the address bar of the browser.

emoncms.org is a completely different instance of emoncms to that running locally on the EmonPi. On first reaching the local instance, you need to ‘register’ the first user.

[edit]
emoncms.org/find did work for me (thing to know) but I was not logged into emoncms.org at the time which apparently you are.

If it doesn’t work it is likely to be the browser or network setup that is preventing it.

1 Like

Thanks Brian. I tried the IP address in the browser without luck. I’ve tried http://emoncms.org/find whilst not logged in and it still didn’t show up.

I’ll trawl the forum, I’m sure this has been resolved before.

So just 192.168.x.x? What is the IP? It might be a default one (un-routeable) as one was not assigned.

Wired connection or Wi-Fi? Have you connected the EmonPi to the Wi-Fi?

I think it’s the default. 192.168.42.1.

I’m trying to connect by wifi, as I’ve not put in the password anywhere but did try the WPS.

I saw a message on the EmonPi: “SSH Enabled?” “Y press and hold”. Will enabling this do the trick?

Hi,

that address means you have not connected to your network yet, on a PC/tablet search in your available wifi networks for your emonpi then connect to it (not sure on the password but it will be in the docs somewhere) then in your browser follow the setup to connect to your wifi at that point the display should show the IP your router has allocated and you can then put that in your browser from any device on your network to connect to it.

John

Hi John - thanks for that. I’m not able to ‘find’ the emonpi. No idea why as the wifi signal is fine where it is. This vid talks about using an ethernet connection to get started so will try that tomorrow. :crossed_fingers:

Hi,

you need to have your device near the emonpi as it is broadcasting its own signal for you to connect to.
Enet will also work if you have that from your network where you want the pi, though if that is the case it is better to leave it on the enet connection. I use powerline adaptors to feed mine is it is in the garage which is too far from my normal wifi.

John

1 Like

You need to use a second device to connect to the EmonPi by Wi-Fi initially.

Reboot the EmonPi and start here https://guide.openenergymonitor.org/setup/connect/#option-2-connecting-via-wifi

Alternatively, plug in an Ethernet cable (choose the correct RJ45 socket - the one next to the USB ports).