Feedwriter: Activating Auto-restartService is not running10 feed points pending write

Hi All,
I used EmonCMS without problems for some years.
My old Synology died for a few days :frowning:
So I bought a QNAP (TS251+), I installed Debian 10 in a container using docker.
Also installed using the script, EmonCMS Version 10.2.2 (low write).
All fine, except two thing.

  1. feedwriter: Activating Auto-restartService is not running10 feed points pending write (after a restart, all data are lost on Emoncms)
  2. I searched over the internet for the right user/password to log me in in the console, no chance to find the right combination of the words, emoncms/emonpi? emonpi/emonpi2016 ?

Any help is appreciated and finally, sorry for my English :stuck_out_tongue_winking_eye:

Hi, welcome,

Did you edit the configuration to suit a Debian install?

Can you

systemctl status feedwriter.service

and post the output.

If you mean the emonCMS WebUI, you need to click register first. There is no default user.

Hi Brian,
Im not able to put the command you suggested.
Im not able to login into the console

for a debian install, I changed only the EmonSD_pi_env=0 (because is not a raspberry), I should to change more things?

Thank you
Remo

No that is fine. How did you run the install command?

after saving the config.ini…I typed ./main.sh

So you should be able to run the command I suggested in the same way.

Ok, I reinstalling it and try your command.
Thank you for your help :slight_smile:

You should not need to reinstall

Im using a docker Debian LXC version, after reboot it ask me for a password that I not have, I try again with another Debian docker version and let you know, finally I think I have to switch to an real raspberry.

I run emoncms for the last 4 years on my sinology, without problems, as my sinology died, I bought a Qnap251+ , and now all these problems happens :slight_smile: I let you know…many thanks for your help

Hi again Brian,
I installed it freshly (Debian 10 LXC on a container), because these LXC package generate a random password, is for me not possible to enter on the system, so I put your command just after the emoncms installation, the result are the same as in this topic, here below the result.

----------------
[email protected]:/opt/openenergymonitor/EmonScripts/install# systemctl status feedwriter.service                                                                                                                        
● feedwriter.service - Emoncms feedwriter script                                                                                                                                                                   
   Loaded: loaded (/var/www/emoncms/scripts/services/feedwriter/feedwriter.service; enabled; vendor preset: enabled)                                                                                               
   Active: activating (auto-restart) (Result: exit-code) since Sat 2020-05-09 11:32:21 UTC; 32s ago                                                                                                                
     Docs: https://github.com/emoncms/emoncms/blob/master/scripts/services/install-service-feedwriter.md                                                                                                           
  Process: 5559 ExecStartPre=/bin/mkdir -p ${LOG_PATH} (code=exited, status=0/SUCCESS)                                                                                                                             
  Process: 5560 ExecStartPre=/bin/chown ${USER} ${LOG_PATH} (code=exited, status=1/FAILURE)                                                  
--------------------------

I expect you can change the password immediately after install? The random password will be so there is not a universal password out in the wild.

So the attempt to change the ownership of the folder is failing on starting the service.

You need to investigate from the command line why this is. The line before seems to say the creating of the folder was a success.

If you cat /var/www/emoncms/scripts/services/feedwriter/feedwriter.service you will see the value of $USER. It could be that, as you did not change the user in the configuration file, this is the issue. The user should be the same as the logged in user when running the install script.

If you install the container as the user pi things will work better. Eles change the configuration for the emoncms install to match the logged in user.

do you mean, I have to set the user in this paragraph below ? Like the user of the Debian container ?
In the console prompt I see → [email protected]

user=pi
hostname=emonpi
emonSD_pi_env=0

Hi Brian ,
thank you so much !!!
It works now :wink:
I created a user in my Debian system and added it in the config.ini

Thanks again for your help :slight_smile:
Wish you a nice week-end

1 Like