Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Feeds updated, but new data won't display

Hello,

Trying to migrate from emoncms.org to a local install, I just installed emoncms on a raspberry pi.
Imported emoncms . org data.
Now :
-Old data displays correctly on my emoncms installation
-My measurement device correctly updates inputs (done with http requests and API key)
I can see new values coming in the “inputs” tab
-Feeds are also correctly updated. I can also see new values in “feeds” tab.

Problem is : when visualizing data, all new data (after migration) doesn’t display.
I can only see old data (which were on emoncms . org). New data uploaded to my fresh emoncms installation won’t display. Neither in the “graphs” tab, nor in the “visualization” tab, not in “my solar” app. Only old data…

What am I doing wrong ?
Thanks for any help !

Hello @fonze did you use an emonSD image to install emoncms on the raspberrypi or is it a custom install? How are you posting the new data?

It sounds like it may be file permissions related, do you see any errors in /var/log/apache2/error.log or /var/log/emoncms/emoncms.log?

Hello @TrystanLea !

Thanks for the quick reply.
I’m using a custom emoncms install, as my raspberry pi has other tasks to do.
New values are posted through an http request like :
http://myserver.org/emoncms/input/post.json?json={...ACP:200....}&apikey=…&node=1
I have 4 inputs in the json part, which generate 6 feeds.

You’re right, it seems a file permission problem. I can see errors in the logs every 10 min, which is my interval for posting new values.

For example, in /var/log/emoncms/emoncms.log :
2021-07-25 05:20:04.559|WARN|PHPFina.php|post() could not open data file id=128823

In /var/log/apache2/error.log :
[Sun Jul 25 07:20:04.551158 2021] [php7:warn] [pid 12517] [client …] PHP Warning: fopen(/var/opt/emoncms/phpfina/128820.dat): failed to open stream: Permission denied in /var/www

Which permission(s) on which files(s)/folder(s) should I set ?
Thanks !

Hello @fonze try:

sudo chown www-data:www-data -R /var/opt/emoncms/phpfina 
sudo chown www-data:www-data -R /var/opt/emoncms/phptimeseries

Hello @TrystanLea,

It solved my problem. It works now.
Thank you very much !

1 Like