Feed page stuck on loading

I updated through git today. The previous login issues are gone, which is good.
However, I am no greeted with a continuous loading of the feed page (circular rotating loading icon).

The console shows the following from process.ui.js:

Uncaught TypeError: Cannot read property 'name' of undefined
at Object.getBadges (process_ui.js:193)
at Object.drawpreview (process_ui.js:148)
at Object.draw (custom-table-fields.js:63)
at Object.draw_row (table.js:144)
at Object.draw_internal (table.js:94)
at Object.draw (table.js:38)
at Object.success (list:528)
at j (jquery-1.11.3.min.js:2)
at Object.fireWith [as resolveWith] (jquery-1.11.3.min.js:2)
at x (jquery-1.11.3.min.js:5)

Also, I have some graphs from feeds that show up as not authorized, but they are set to public! When logged in they work fine, seems the public tags does nothing?

I had a similar issue. Solved it by making sure I ran a git update in all modules subdirectories

Thanks, but i ran through all directories to be sure, everything was up to date!

I have the same problem, although mine might be from a DB restore I just did because of hardware failure.

My Inputs page is fine - and everything is ok otherwise.

From the admin page, have you updated your database?


Yes - first time I updated after the “restore”, there were some things to fix, but I didn’t write them down.

Now there are no pending actions. DB checks fine.

All of my feeds are working, I just can’t edit them…

Is there something I can reset?

Are all the Modules up to date?

Yes - all up to date. Just did a git pull to check.

Just to be sure, some of the modules have to be updated individually and not just using a git pull from the emoncms folder.

What is your setup?

Can you please post the details from the administration page? Click on the ‘copy to clipboard’ button next to the ‘server infomation’ header.

Bart said;

…and you followed with;

Lets be clear here, if you have the same problem, do you see the ‘circular rotating loading icon’??

I’m going to move to a new thread to keep things clear. Thanks all!

My problem went away after an update a few days later.

For future reference - see Feeds page stuck with rotating graphic - #7 by bb512 for possible solution.