Emontx4 wifi to emonpi (sd)

Hi All,

I am new to this community but i would like to say thanks in advance!

I have purchased a emontx4 WIFI and loaded the emonpi imiage onto an existing RPI3. Both EMONPI and ESPWIFI are on my network. I have a Type1 solar system setup. My CT leads are on and i can see some data in the ESPWIFI UI.

I thought i would need to create a new device in emoncms (unsure what the device key is in this screen). In the ESPWIFI UI, under the emoncms, i have tried emonpi (as this is in DNS) and the currrent IP, node name matching emontx device, and the wrrite key from my emoncms. When i click connect nothing changes. I installed tcpdump on my emonpi and cannot see the emonwifi device try and post anything :(.

I apologise in advance if this is well documented somewhere but i have looked … honest ;).

Hi Welcome.

I am not totally familiar with the SW on the ESP device, but you need to tell the ESP device to send the data to the Pi (I’ll refer to the Pi as an emonBase).

Have you subscribed to the online system emoncms.org?

I will assume not. In this case, on the emonBase, in the emoncms UI, look for details for your API Key under the My Account section

There will be a section on the ESP UI to put in the IP address of the emonBase (under Admin in emoncms), plus the API key. If you can, please set the emonBase with a fixed IP (via your router).

Once you have done that, you should see data appearing in the Inputs of the emonBase.

Come back once that is working :slight_smile:


thanks for getting back to me. I have set a static ip for emonBase ( UI is accessible via this IP in the browser. I have accessed the emontx4 ESP UI via Applied the credentials on the admin ui of the ESP but still shows not connected :(.

I have tried adding ‘/input/post’ in the path section but still no joy. A network capture on the emonBase shows no attempt to post from ESP when i save the config.

Did you try the suggested /emoncms?

Otherwise @TrystanLea, @glyn.hudson or @Gwil may be able to help.

Hello @Mark_Mooney

Do you see any data in the Latest Data tab? It sounds like the data may not be getting through to the WiFi adapter itself

EmonTx4 data output is passed to the ESP8266 WiFi adapter via serial. Sounds like something might be not working correctly with that internal link?

1 Like

@borpin - i did. I do not see the ESP try to send anything to the IP. If i had the wrong URI, i would still expect to see a post initially :(. Unsure how to debug the ESP as the emoncms option appears broken.

@TrystanLea trystanLea - no data

Thanks @Mark_Mooney can you plug a USB-C cable into the EmonTx4 and monitor the serial output using something like the Arduino IDE serial monitor? Can you confirm that there are 10s readings being printed on over serial via the USB cable?

Could you take the EmonTx4 out of it’s enclosure and take a picture of the top and bottom side of the WiFi adapter? I wonder if we’ve missed something with our quality control and there’s a dry solder joint or something. Might be worth checking the bottom of the EmonTx4 PCB as well where the 6 pin header’s are located that link through to the WiFi adapter board.

We are also happy to take a look at this for you of course if you would prefer to return the unit to us. Please email us at [email protected] if you would like to arrange that.

@TrystanLea @borpin

success! i opened it up as suggest and found the ESP8266 not not fully pushed home to the emontx. I reseated and i now see data. emoncms is now showing connected. I will monitor it but hopefully that has sorted it.

Many thanks both!