Emontx v3 stopped working


I hope someone can help me. Over a year ago I bought two eamontx v3’s and a emonbase for my solar and house consumption and production. Them have all been working flawlessly until a few weeks ago when the tx for the solar output stopped sending data. I tried turning it off and on again. The red light used to go on and off every ten seconds or so like the working tx, but now the red light just stays permanently on. Can anyone help?


It sounds very much like the radio module has failed. The first thing to check is the soldering for the module. Have all the joints got a visible fillet of solder between the connections on the edge of the module and the main circuit board? Can you see a hairline crack anywhere? If you press on the module and then push the reset button, does it work? If you have a fine-tipped soldering iron, you could try remaking the joints on the radio module.

If you have a programmer, try commenting the lines of program that initialise and use the module
rf12_initialize(....., rf12_sendNow(... and send_rf_data( ...
If it sends to the IDE Serial monitor and the LED flashes, then it’s almost certainly the module.

If you can’t see anything obvious wrong, I’d suggest you email support. Unless you have experience and the tools, I would not recommend trying to remove the radio module yourself.

I think you might be right. When I connect the tx to computer through Arduino I get this in serial monitor:

emonTx V3.4 Discrete Sampling V1.80 RFM69CW
POST…wait 10s

Red light stays on and that’s all that happens.

If I remove those three lines of code you suggested I get this:

emonTx V3.4 Discrete Sampling V1.80 RFM69CW
POST…wait 10s
CT 1 Cal 90.90
CT 2 Cal 90.90
CT 3 Cal 90.90
CT 4 Cal 16.67
RMS Voltage on AC-AC is: ~1V
AC-AC NOT detected - Apparent Pwr measure enabled
Assuming VRMS: 230V
Assuming power from batt / 5V USB - power save enabled
NO CT’s detected
No temperature sensor
Node: 8 Freq: 433Mhz Network: 210
19161 0 0 0 498 0
4512 0 0 0 502 0
1062 0 0 0 500 0

I tried re-soldering the module with no change. So do I just need a new rf module?


Clearly, the sketch is hanging when it tries to initialise the RFM69, which doesn’t respond.

Yes, but…
As I warned, it is quite hard to remove the module from the main PCB without damaging the main board. If you have access to a rework workstation, and you’ve done it before, there should be no problem. Otherwise, I recommend you get in touch with support at the shop and see what they say.

Thanks very much. I contacted the shop to see what they say.

Thanks for all your help :slight_smile:

Very sorry to hear. Thanks for getting in touch. Replacement is on it’s way. Please confirm this fixes the issue.

I will examine the faulty unit once it’s returned to us.

Out of interest, what environment have the units been running in? Up until now has the unit been reliable for the past year or so?

Hi Glyn,

Cheers. The tx was in a dry shed with the solar inverter. It was working 100% this past year until it just stopped.


Hi Glyn
Did you find a root cause for this problem?
I seem to be having the same issue. Ordered an emonTx v3.4 December 2016 and it used to hang every few months. Now with growing frequency … 31 October 2017, 20 Nov, 28 Nov, 14 Dec.


Sorry, I can’t remember what the outcome was of the return unit testing. It might have been organised by one of my colleague. It’s very strange that your still having the same issue. It points to a possible RF transmission or maybe a power issue.

What is the RSSI of the received signal? How far is the unit from the base station?

What power supply are you using to power the emonTx? Is it the same power supply as before?

Are you sure the issue is with the emonTx hanging and not the emonBase / emonPi? Does the red LED on the emonTx stop flashing when the emonTx hangs?

RSSI is -45 to -50 give or take.
10 metres
Same power supply - AC­AC Power Supply Adapter ­(UK Plug). We are 240V here in Australia.

Yes red LED stops flashing every 10 seconds. Power cycle fixes it. Flashes 10 times to show AC-AC has been detected and then once every 10 seconds until the next freeze.
emonHub keeps working. emonHub very stable. Only rebooted for upgrades. (low-write 9.8.25 | 2017.12.08)

3 Current sensors and one temp. Running shipped firmware.


The emonTx just crashed again. Same symptoms, LED stops flashing, emonHub up and running OK. Power cycle of emonTx returns normal operation.
Last reported RSSI was -51
Temp at emonTx: 25.5°C
AC volts: 237

Unless you have any ideas I think this is a warranty return


Do you have any ancillaries connected to the emonTx? Apart from the one temperature sensor as you mention, is there anything else connected that draws current?

My thinking is there’s an outside chance that you have a very worst case set of components and a dip in the mains just as the emonTx transmits might have been enough to crash it, but not enough to cause it to reset itself. I’ve never been able to make one do that, but I don’t rule out the possibility. If you have a 5 V USB supply spare, it might be worth trying that.

It’s very strange you are having the same issue with the replacement unit. The points to a possible power supply issue since the same power supply is being used with the replacement unit.

Could you test powering the unit via 5V DC using the USB socket instead of AC. Note: when powering via DC the red LED won’t flash as the unit will enter a power save mode since it things it’s being powered by batteries.

As Robert suggested it would also be a good idea to disconnect the temperature sensor in case there is an issue with the sensor that is causing higher current draw.

@glyn.hudson - I think this is a new case. Damien (the original poster) last posted 4 months ago, Peter has not previously posted and is now asking

Ah sorry for the mixup. My mistake

Yes Paul @pb66 is correct. This is a new case.

To summarise:

emonTxV3 mounted within 1 metre of switch board (Purchased December 2016)

RSSI is -45 to -50 give or take at emonBase
Distance to emonBase: 10 metres

AC­AC Power Supply Adapter ­(UK Plug). We are 240V here in Australia.

3 CTs and one temp sensor (DS18B20 RJ45 attached).

Running shipped firmware.

No ancillary devices.

Happy to try powering it with 5V DC. Will have to pull JP2.

Regards and Thanks