emonTx Shield V2 SMT PCB Design files will not open in Eagle (Solved)

Hi

I just downloaded the sch and brd files and neither will open with my version of Eagle.

Loading G:/Downloads/EmonTxShieldV2.5.sch …

Error:

line 8, column 16: This is not an EAGLE file.

Any suggestions?

Ian

G: ?
Is that a local drive? How did the file get there? I’m thinking you might have line numbers, which aren’t part of the Eagle file.

I’ve got a set ( .brd & .sch) downloaded in July 2013 that Eagle opens quite happily. The first few lines, opened in an ordinary text editor, are

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE eagle SYSTEM "eagle.dtd">
<eagle version="6.4">
<drawing>
<settings>
<setting alwaysvectorfont="no"/>
<setting verticaltext="up"/>
</settings>
<grid distance="0.1" unitdist="inch" unit="inch" style="lines" multiple="1" display="no" altdistance="0.01" altunitdist="inch" altunit="inch"/>
<layers>
<layer number="1" name="Top" color="4" fill="1" visible="no" active="no"/>
<layer number="2" name="Route2" color="1" fill="3" visible="no" active="no"/>
<layer number="3" name="Route3" color="4" fill="3" visible="no" active="no"/>

Yes G: is a local drive.

But my files must have got corrupted. Look nothing like yours in editor. Downloading again.

Thanks for the pointer I did not know they were text files.

Ian

I think I’ve opened the “raw” file in a web browser, saved and renamed it .brd or .sch as appropriate.

What version of eagle is this? Can you open other openenergymonitor eagle files? e.g. emonTx, emonPi, emonTH etc?

Hi @glyn.hudson

Problem solved. The files I first downloaded were corrupt. Downloaded complete Zip and files were fine.