EmonTx not giving out serial data

Just set up a new EmonTx and have been having trouble getting anything from it. Connected it to a USB UART adaptor and all I an getting out is this:

emonTx V3.4 Discrete Sampling V3.10

No EEPROM config
RFM69CW Node: 8 Freq: 433Mhz Group: 210

POST…wait 10s
‘+++’ then [Enter] for RF config mode

and it just stops. No more updates, nothing. I have tried to upload a new sketch but there are no clear instructions on how to get the emonTx into a mode where I can upload a sketch.

No CT’s connected, powered by USB for now for debugging purposes.

Hello Justin, welcome to the OEM Forum.

I’m sorry you appear to be having a bad experience with your new emonTx.

It does rather sound as if you have a faulty RFM69CW radio module.

If you look at the sketch, the first significant thing it does after the “+++” message is initialise the RFM. If that fails, the sketch hangs there and can’t proceed.

Presumably, you’ve tried entering “+++” and get no response?

I suggest you email the shop [email protected] and mention this thread. They’re all away until later in the week, so they won’t answer straight away.

There aren’t instructions to put the emonTx into “upload” mode because you don’t need to. Just click “Upload” to compile and upload the sketch from the Arduino IDE. It ought to ‘just happen’.

1 Like

I’m experiencing the same issue with my board.

Connected it to a USB UART adaptor and all I am seeing the following:

> emonTx V3 EmonLibCM Continuous Monitoring V1.50
> OpenEnergyMonitor.org
> No EEPROM setting found...using default values
> Calibration:
> vCal = 268.97
> i1Cal = 90.90
> i1Lead = 4.20
> i2Cal = 90.90
> i2Lead = 4.20
> i3Cal = 90.90
> i3Lead = 4.20
> i4Cal = 16.67
> i4Lead = 1.00
> RFM69CW Node: 15 Freq: 433MHz Group: 210
> RFM int...
> '+++' then [Enter] now to enter config mode...5s
> NO CT's detected

I tried with and without flow control, and to enter “+++[Enter]” each time and nothing happens.

Is this an issue with the RF module ?
Is there anything else I can try to diagnose if this is the issue ?\

Thanks, regards, Kieren.

On the face of it - no. Usually, the RF Module won’t respond at all if there’s a problem with it. In your case, it has initialised (because it got as far as NO CT's detected). You should see “AC present” (or “AC missing”) before the radio is used again, and you don’t.

Do you have the a.c. adapter connected? For a reason I don’t yet understand, that sketch seems to hang (for me) when I disconnect the a.c. adapter, but continues (not restarts) when I reconnect it. It’s not a problem with the library - the demo sketches that I produced with the library continue to run provided there’s an alternative power supply of some sort and report a tiny noise voltage.

@TrystanLea created the sketch so he might have some ideas. He is presently testing what I think is a more reliable version that’s much closer to the demo sketches, I don’t know whether he’s happy with that yet, and is prepared to release it.

Hi Kieren,

Unfortunately I don’t have any insight into the matter. When I contacted support they said it was a faulty RF module. They have since given me a replacement and it has worked well from that point on. Sorry I can’t be more of assistance in the matter.