Community
OpenEnergyMonitor

Community

Emontx Firmware Update- pulse missing from inputs

Tags: #<Tag:0x00007f6e0f216220>

Good Evening,

I have recently updated the firmware from Discrete to CM sampling on my Emontx V3.4 and found that the node number had changed from 8 to 10. I went through a set up all my feeds and got the apps up and running.

Strangle though the pulse sensor connected to the rj45 is lighting up when the meter pulses but there is no count on the inputs page?

Any idea why this might be?

Thanks

Gareth

Pulse counting is optional. Did you enable pulse counting in the sketch? Does it show as enabled if you go into the on-line calibration mode at start-up? Although the default is “enabled”, it may well be that the new sketch picked up the “disabled” setting that was left behind in the EEPROM.

Has the optical pulse sensor itself worked with the old sketch, and has it been disturbed? The reason for mentioning this is the green LED on the back and the presence of a pulse aren’t necessarily the same thing - but from memory it’s in the direction of the output being a digital ‘high’ (i.e. the pulse will be detected) but the LED stays off. The sensor output is not truly digital, it’s an overdriven amplifier from what I found, and the LED appears to obey slightly different rules.

Hi,

Thank you for your response :slight_smile:

Pulse counting is optional. Did you enable pulse counting in the sketch? I did notice that in the sketch pulse counting was set to ‘false’. I set this to ‘true’ even though emonlibcm states that it is enabled.

Does it show as enabled if you go into the on-line calibration mode at start-up? I havent tried this but will do. Not quite sure how to do this but will do a search.

Although the default is “enabled”, it may well be that the new sketch picked up the “disabled” setting that was left behind in the EEPROM.

Has the optical pulse sensor itself worked with the old sketch Yes it worked fine, and has it been disturbed? No it hasnt, I unplugged and reseated the connections just in case. The reason for mentioning this is the green LED on the back and the presence of a pulse aren’t necessarily the same thing - but from memory it’s in the direction of the output being a digital ‘high’ (i.e. the pulse will be detected) but the LED stays off. The sensor output is not truly digital, it’s an overdriven amplifier from what I found, and the LED appears to obey slightly different rules. Ah ok im with you, thats interesting to know. Its more of an indication led as oppose to an input?

Thanks

Gareth

You should not need to touch emonLibCM itself - you should use the API calls to set things. The defaults are there so that the absolute minimal sketch (in the examples) will “work” and give sensible results.

The EEPROM, if it found and appears to have data in it (and there was a big omission when this option was added because there is absolutely no checking for the sketch that the data applies to) then it will override the default values set in the sketch. You can erase the EEPROM (but then you’ll lose any calibration that you put in there from the old sketch) from with the new sketch - again that’s available at startup.

The instructions for the on-line calibration appear at the serial output when you power up or reset the emonTx. There’s no documentation for that with emonLibCM because it’s not part of the library.