Emonpi wont start after emonsdexpand is run

I have downloaded the nov 2016 sd card image and installed on a RPi3.
Configured the localisation and network connectivity.
Checked that I can connect via a browser to emoncms. Ok
Run emonsdexpand as I am using a 32GB samsung sd card and reboot.
emonpi now not working.

  • sql not started
  • no files in the /home/pi/data folder.

retry from scratch but before the sdexpand I copied all the files from the /home/pi/data folder to a backup, then after expand I copied them back but mysql wont start?

Note: I have nothing else connected to the pi other than power and a local keyboard and monitor.

What ouput messages did you receive from emonsdexpand?

emonsdexpand runs the following scipt located in ~/usefulscripts/sdpart/sdpart_imagefile:

This can take a while, up to 20min

I admit to not fully understanding the message and assumed that once it rebooted all was well. I tried the May image and got distracted for about an hour after the reboot and everything was OK.
I tried again with the November release and waited for 30 minutes but it still didnt work. It has now been running over night and this morning it had shut down. Upon restart it looks like it was successful.
BTW, the final message in the script was shown on the screen before the first reboot ie
“so far so good …
… unusable filesystem”

But after reboot everything just looked normal.
Thanks for the reply, and sorry to have troubled you.