Emonpi Update overwrites custom settings.php


Just getting set up on emonSD-03may16 image. Unusually for historic reasons I use an mqtt broker on a different server.

I changed settings.php to my broker and very thing worked fine.

This morning I tried the update now command to make sure everything was up to date. A little later in the day I realised my mqtt inputs were not updating. On investigation I found settings.php pointing back to localhost. Presumably because of the update now command.



Hi Ian,

Sorry this has caused you trouble. We should try and make more clear that the emonpi update is aimed at ‘stock’ emonPi’s. If you are customised your setup I recommend you update manually using git pull etc.

Emonpi update does backup the setting file before overwriting.

A option to toggle this behaviour would be nice…