Community
OpenEnergyMonitor

Community

Emonpi unable to add feed

Hello all,

New here so please forgive me if I’m posting this in the wrong place, I’m trying to add my first feed but every time I try I’m getting an error that /home/pi/data/phpfina/x.meta is missing, the x changes number every time I try to add a new feed.

any ideas where I can start troubleshooting this at all? I have logged on the to SSH terminal and there is no folder structure under /home/pi

Not sure if I need to create something here or I have done something wrong

Thanks folks !

Hello @Matt_Bradley is this a new EmonPi from our shop? It sounds like there is a settings error and there have been a couple of reports of something similar but in a different part of emoncms. Perhaps there is an underlying issue…

1 Like

Hi Trystan Lea, Yep new Emonpi arrived this morning, ordered it yesterday (amazing delivery time to the middle on nowhere !)

Thanks @Matt_Bradley, could you copy here the result of:

cat /var/www/emoncms/settings.ini

It should be similar to https://github.com/openenergymonitor/EmonScripts/blob/master/defaults/emoncms/emonpi.settings.ini but with the settings in capitals replaced.

[email protected]:~$ cat /var/www/emoncms/settings.ini
emoncms_dir = “/opt/emoncms”
openenergymonitor_dir = “/opt/openenergymonitor”

[sql]
server = “127.0.0.1”
database = “emoncms”
username = “emoncms”
password = “emonpiemoncmsmysql2016”
; Skip database setup test - set to false once database has been setup.
dbtest = true

[redis]
enabled = true
prefix = ‘’

[mqtt]
enabled = true
user = ‘emonpi’
password = ‘emonpimqtt2016’

[feed]
engines_hidden = [0,6,10]
redisbuffer[enabled] = true
redisbuffer[sleep] = 300
phpfina[datadir] = ‘/var/opt/emoncms/phpfina/’
phptimeseries[datadir] = ‘/var/opt/emoncms/phptimeseries/’

[interface]
enable_admin_ui = true
feedviewpath = “graph/”
favicon = “favicon_emonpi.png”

[log]
; Log Level: 1=INFO, 2=WARN, 3=ERROR
level = 2
[email protected]:~$

Great that looks fine. Is there by any chance a file called settings.php:

ls -lh /var/www/emoncms/settings.php

[email protected]:~$ ls -lh /var/www/emoncms/settings.php
-rw-r–r-- 1 root root 6.9K Apr 28 11:32 /var/www/emoncms/settings.php

there is indeed, do you need a copy of that as well ?

ok that looks like the problem, it seems to have a copy of the old settings file in place. If you remove that with:

rm /var/www/emoncms/settings.php

and then reboot the emonpi, could you check if the system works as expected.

I will try and investigate here why that file might be there.

1 Like

Thank you Trystan that seems to have sorted it !

Great to hear @Matt_Bradley, is there any chance that you could copy the result of the bash history:

$ history

We think this may have been caused by our mistake running the wrong factoryreset script in the shop.

sorry of course the factoryreset script cleans the history so it should be mostly empty appart from your recent commands.

Could you check that the Setup > Admin > Full Update works?

Yep was just about so say other than what i have done it blank sorry

1 Like

That’s good to know, I dont think your system will be otherwise adversely affected, we do spot checks every now and then of EmonPi’s in the shop by logging in and creating an account, checking that the data comes in and then running the factoryreset script, but it looks like we ran the old version which would have added the settings.php file but from what I can tell should not have broken anything else.

I realise the link to the script in our documentation was incorrect and I have now updated it https://guide.openenergymonitor.org/setup/troubleshooting/

It might be worth checking that Setup > Admin > Full Update runs ok.

This looks like the second time this has happened recently.

Yes, that is strange, we’ve checked a number of emonpi’s in the shop and they don’t have the settings.php file and the master is ok as well. So we are putting it down to running the wrong factoryreset script twice.

1 Like