Community
OpenEnergyMonitor

Community

EMONPI stopped connecting to emoncms app

Tags: #<Tag:0x00007f6e0f01b6f0>

I amrunning an EMONPI solar setup, purchased in march 2020,It has been running OK for 3 months,
then last week I was unable to connect to graph on emoncms, to show generation,
I had to shutdown the EMONPI and re-boot then this worked, I am shutting down with holding the button on front of EMONPI, this happened for a few days,
Now I am unable to connect at all after rebooting,
This is running on wifi, the EMONPI, shows on screen that the wifi is connected, the CT1,CT2 is Blank, on the next screen its showing connecting, and has been like this for several days,
I am a newbie not into programming, it took a while to get graph showing on emoncms,
Is it a matter of just swapping the internal SD card or can a new programme be loaded through emoncms
Shop invoice 22728
invoice 17964
EMONPI Serial No. 45A38B2A, SD card write 17 OCT 2019

Hi Brian, welcome to the community. We are not a help desk but will do our best to get you back running.

You will need to try and connect to the emonPi directly via SSH. Have you done that before?

What sort of computer do you have Windows / Linux?

Ive got a windows computer, only way I have connected is through its ip adreess on emoncms
I have not used SSH, on the EMONPI the SSH is turned off

Ok - every day is a learning day.

If you press the button on the emonPi it will cycle through messages until you get to enable SSH. Press and hold to enable it.

My PC is not setup as standard so I cannot test this bit exactly, but I think you should be able to, on your Windows machine, click on the windows icon (bottom left) - or the search box and type powershell

image

Click on that icon and then type ssh [email protected]<yourIPaddress> then press the **<rtn>**key in the console window that opens.

Then the password emonpi2016.

Let me know how you get on with that.

turned on ssh
got onto powershell
typed in info
coming back :- ssh: could not resolve hostname ip address no such host is known

Did you type in the IP as you type in the browser to access emoncms?

typed ssh [email protected], 192.168.1.245

All together as in

ssh [email protected]

tried again leaving out the , now works
inputted password
mow at
[email protected]:-$

1 Like

Now copy the text below, then click on the powershell window and right click - it will paste the text then <rtn>

sudo du -ah /var/log/* | sort -n -r | head -n 30

You should get a few lines of text.

Highlight the text the <ctl-c> to copy it.

Create a new post on the forum so you can show me the text.

type 3 ‘backticks’ (it is usually the key in the top left of the keyboard) so

```

Then on the next line paste <ctl-v>

and then 3 more backticks.

Post the message.

message come back as
-bash: ctl-v: command not found

The second part is to paste the output text here. I have edited the above so it is clearer.

Ah, just copy the single line

sudo du -ah /var/log/* | sort -n -r | head -n 30

I cant copy and paste text from powershell

done the second copy and paste

OK press the windows key on the keyboard and the shift and the ‘s’ key all together

<win><shift><s>

And take a screenshot of the powershell window and then, in a reply, <ctl-v>

1 Like

Ok, odd that looks fine.

I see you typed the backticks into that window. The backticks are for the forum post so I think if you select the text in the powershell window and <ctl-c> you should be able to copy the text to paste into a post.

Next things to try is these 2 commands - again I’ll need to know what the output was

Do one at a time

sudo systemctl status {emoncms_mqtt.service,service-runner.service}
sudo systemctl status {emonhub.service,feedwriter.service}

I have copyied 1st line but unable to do second due to line end

Just hit q to exit that.