Community
OpenEnergyMonitor

OpenEnergyMonitor Community

emonPi not working following several power cuts

Following several power cuts a couple of days ago, I discovered that my emonPi was not working. It starts up as normal, reporting “EmonPi V2.92”, AC wave detected and no CTs (none plugged in so I guess that’s good!), and no temp inputs (likewise). It then just displays “Booting…Please wait”.

I have read various posts on this topic, and have tried the following:

  1. I have reflashed the supplied 16GB SD card using the Raspberry Pi Imager app on my Windows 10 PC. This completed without error, but re-inserting the SD card made no difference.
  2. I also tried flashing a new Kingston SDHC Class 4 card I had (albeit only 8GB) - this also completed OK, but the unit could not boot on that either.
  3. I have established that the emonPi is configuring its IP address, even though it does not get as far as displaying it, and I can ping it reliably on my local network.
  4. I can also SSH into the unit, using its IP address, username pi, but had to use password ‘raspberry’ (emonpi2016 did not work). Having got access, I’ve no idea what to do in there, so this is for info only.
  5. There is no response from the address on a web browser.
  6. Neither the front panel pushbutton, or the one on the PCB have any effect.

Given the above, can somebody suggest what should be my next steps to getting this working again.
Thanks.

Hello @schematech it sounds like you have flashed the stock raspberry pi OS image onto the SD card?
You can download the latest OpenEnergyMonitor emonSD image from here: https://openenergymonitor.org/files/emonSD-08May21.zip and then we generally recommend using etcher to flash the image as its easy to use balenaEtcher - Flash OS images to SD cards & USB drives

Ah - I see. OK. I’ll try that and see where I get to.
Thanks, Trystan

Hi @TrystanLea - I flashed the image you linked to on the original 16GB card. etcher did all the writing OK, but at the end of the verify pass it just said “flash failed”.
I thought I’d try it anyway, and the emonPi got further this time. It reported its IP address OK and looked like it was going to work. Then it said “Updating…DO NOT UNPLUG!” for about 10 minutes, before reverting to normal screen.
The front push button now cycles through the various screens. It has the correct date/time. The web browser interface now works.
Should I ignore the “flash failed” message and continue to set everything up again?

Also - and importantly - what can I do to protect the unit from power failures in the future? I have a small UPS available, which would help with spikes, but not ultimately against “pulling the plug”.

Thanks for your help and advice.
Bob

Great, that sounds like it has installed ok, perhaps it was just the verification step that failed…
I installed a surge protector on mine and that seems to last much longer now through a large number of power cycles. A small UPS might give further peace of mind

Thanks @TrystanLea - all working OK now. UPS/surge protector being added today!
Bob