emonPi can't measure any data


I’m trying to reach my emonpi data on local CMS, I had a clock problem but it has been solved by connecting emonpi with ethernet wire. It worked for an hour, we had inputs on the emoncms but then the emonpi started to upload and boot everytime. Now, the problem of boot/upload is away. An other problem occur, we can’t measure any power with emonpi, we only see 3 dash. And on the next screen it is printed “Connecting … please wait”. I don’t know how to fix this problem.

Thank you for any help you could bring.

Is this a recent install?

It has been bought 2 years ago.

If it has been working fine, I’d strongly suggest it is the SD Card that is the issue and it is failing.

You can either purchase one from the shop or use the image available.


If you use the Image, get a high quality card such as https://www.amazon.co.uk/gp/product/B07P14QHB7/ and a USB adapter.

I tried with an SD Card with the image available.
The card is a microsd 32GB/Go class 10 EMTEC brand.
I launched the emonpi with the new SD but it’s booting for 2 hours now…
I saw on the link you give that it may take a while but 2 hours seems a bit too long.
Do you have any idea to justify that time ?

Have you tried connecting to the IP address from a browser? Sometimes the display gets stuck.

Did you create an SSH file? If so, then you can try SSH, otherwise you need to reboot and see what happens :frowning:

I actually did mine the other day and it just worked!

I tried to reboot with the button on the emonpi. I saw that the raspberry is shutdown but not the screen.
Ok so you just downloaded the emon image. For me it is the emonSD-10Nov22 (Stable).
And then you add the SD Card into the emon ?

I can’t connect with SSH due to the booting of the emonpi.

Did you try a new card? If the card is failing you must use a new one. In addition, if the same as the old card, you will have lost your setup unless you did a backup first.