Community
OpenEnergyMonitor

Community

emonGLCD time not updating


(Robert Wall) #21

I don’t have a working emonCMS, so I can’t join in. It might be that one page (2) is not getting the time updates, but taking the time from the internal timers. Without checking, I can’t say.

But whichever, it looks like commenting the line and setting the interval to zero is wrong. It should be either commented out but with a sensible default, or not commented and 0 means “Don’t send the time”.


(chris_cronin) #22

I agree.
I only tried setting interval = 0 out of curiousity; now reset to 60 second interval


(Robert Wall) #23

So you’ve now got the functionality that you want to replace the NanodeRF?


(Paul) #24

It doesn’t need to be commented, it could have been omitted or set to zero.

Correct (or at least that’s how it was originally coded)

If it truly transmitted continuously, it wouldn’t be able to receive.

That would make sense. AFAIA the time would continue to tick on the emonGLCD, it just isn’t getting the correction update from the emonbase, so it could drift. That is why the recommended setting is 300, so as to just keep it in line every 5mins, even that is possibly too often.

Indeed, it originally used to be set to 300 and commented out, by default a value of zero is then set internally


(Robert Wall) #25

Thanks for that, Paul. It’s all pretty much as I thought. It seems like the ‘belt and braces’ approach has actually caused problems here.

I’ll point @Gwil here and suggest it is changed.


(Robert Wall) split this topic #26

6 posts were merged into an existing topic: emonTx v2 not passing data to nanodeRF


(Robert Wall) split this topic #27

A post was merged into an existing topic: emonTx v2 not passing data to nanodeRF